Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Feedback The Frustration with Unity Engine Update Process

Discussion in 'Editor & General Support' started by IJM, Feb 13, 2023.

  1. IJM

    IJM

    Joined:
    Aug 31, 2010
    Posts:
    143
    Hello everyone,

    I hope this post finds you well. I am writing to voice my disappointment with the update process in the Unity engine. While I understand the importance of updates, the forced re-importing of all files, even for minor updates, is a huge source of frustration for me.

    Every time there is an update, I have to spend hours going through the tedious process of re-importing all my files. This not only takes up valuable time but also disrupts my workflow and overall productivity. It's a complete waste of time and resources. Due to this, I try to avoid updates as much as possible, but unfortunately, I am often forced to update due to external dependencies.

    I am aware that this issue can be resolved with a better technical solution and it should not be mandatory for users to go through the re-importing process every time there is an update, even for minor ones. The Unity engine is a powerful tool, but the update process is detracting from its potential and making it a frustrating experience for users like myself.

    I would love to hear from others who share the same frustration and also from the Unity team to see if there is anything that can be done to address this issue.

    Thank you for your time and consideration.

    Best regards,
    Ivan
     
  2. chemicalcrux

    chemicalcrux

    Joined:
    Mar 16, 2017
    Posts:
    726
    Dealing with the re-importing process is significantly less painful than dealing with subtle bugs caused by an inconsistent Library.

    You do not need to update every time a new point release comes out. What external dependencies do you have that demand you stick to the very latest version of the editor?
     
  3. IJM

    IJM

    Joined:
    Aug 31, 2010
    Posts:
    143
    Yes, I do understand that. That's what I wrote, that I'm avoiding it in every possible situation. I've been using Unity for 13 years, professionally.

    Today it was the new PS5 SDK.
     
    chemicalcrux likes this.
  4. chemicalcrux

    chemicalcrux

    Joined:
    Mar 16, 2017
    Posts:
    726
    Ah, fair! I think you know better than I do, then :D

    I can definitely believe that third-party platforms SDKs would be particularly sensitive to your editor version. And I can also believe that most of your Library isn't going to change after a minor version bump.