Search Unity

TextMesh Pro TextMeshPro text doesn't show up in built game

Discussion in 'Unity UI (uGUI) & TextMesh Pro' started by HewwoCraziness, Jun 27, 2018.

  1. Jes28

    Jes28

    Joined:
    Sep 3, 2012
    Posts:
    377
    Once. About 8 weeks ago. And as I say bug persist even after Unity Version Upgrade

    UI Envoronment
    upload_2019-9-4_15-49-0.png

    Small Prefab
    upload_2019-9-4_15-52-17.png

    There is no another scales in hierarchy canvas is the only one.

    Tried to add ForceMeshUpdate() into context menu of perk item. Nothing changed.
     
  2. Smorc_IRL

    Smorc_IRL

    Joined:
    Aug 19, 2018
    Posts:
    2
    I had a similar error, the text did not clear in the build. The problem was solved in a very strange way: I just copied the TMP UGUI component values, reset it and paste the values back. After that everything worked fine. I hope this helps someone
     
  3. CDGKen

    CDGKen

    Joined:
    Jun 28, 2019
    Posts:
    11
    I've run into the same issue but managed to find a fix, but only in certain scenarios, which is super baffling. (NOTE: I haven't tried re-pasting all the component values as mentioned above because we use a ton of TMP objects and it would be impossible to find them all).

    Our code generates TMP objects at run-time and I figured I may have accidentally swapped between using UGUI and World TMP objects as suggested by Stephan earlier in the thread. So to be absolutely sure, now whenever I generate a TMP object via code, I do an extra check to determine (check for MeshRenderer or check for RectTransform or whatever) if I should make a TMP obj that uses Mesh or Canvas. That seemed to fix things, but only when the build is run under Fantastic or Beautiful quality settings. Anything less than that and it goes back to invisible text. That's not an issue for me since I plan to lock the quality settings when we build for final, but it's weird behaviour that I figured I'd bring up.

    I'm using 2019.1.9 with TMP 2.0.1 btw.
    (I should also mention the different quality settings are the default ones in Unity)
     
    Last edited: Sep 10, 2019