Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

TextMesh Pro TextMesh Pro package version 2.0.0 for Unity 2019.1 requires .Net 4.x Scripting Runtime

Discussion in 'Unity UI (uGUI) & TextMesh Pro' started by Stephan_B, Apr 16, 2019.

  1. Stephan_B

    Stephan_B

    Unity Technologies

    Joined:
    Feb 26, 2017
    Posts:
    3,050
    Since the old .Net 3.5 Scripting Runtime was deprecated in Unity 2018.3, it will be necessary to upgrade the Scripting Runtime of your project to use .Net 4.x when upgrading to Unity 2019.1 and to the version 2.0.0 of the TextMesh Pro package.

    To switch the project to .Net 4.x, go to the menu "Edit - Project Settings" and switch the Scripting Runtime version to .Net 4.x as seen below.

    upload_2019-4-16_14-24-59.png
     
    Last edited: Apr 16, 2019
  2. nkcowmaster

    nkcowmaster

    Joined:
    Jun 28, 2013
    Posts:
    4
    Exactly what I needed. Thanks!
     
  3. jayatubi

    jayatubi

    Joined:
    Dec 9, 2013
    Posts:
    65
    Any new features compare to the 1.4.1?
     
  4. Stephan_B

    Stephan_B

    Unity Technologies

    Joined:
    Feb 26, 2017
    Posts:
    3,050
    1.4.1 and 2.0.1 are the same with the exception of 2.0.1 having a dependency on UGUI and using .Net 4.x (mostly the syntactic sugar part of it for the time being).

    UGUI was supposed to be a package for 2019.1 but didn't make it in time. A wrapper was added to allow TMP to treat the still internal UGUI as a package so that when UGUI become a package, version 2.x of TMP will simply work.
     
  5. MrPhilipJWilliams

    MrPhilipJWilliams

    Joined:
    Nov 4, 2018
    Posts:
    1
    This fixed it. THANKS :)
     
  6. WhitethornDigital

    WhitethornDigital

    Joined:
    Aug 12, 2018
    Posts:
    9
    Weird question, but we're working on porting a game using the 2017 LTS that is written in .NET 4.6. Is it possible to get the .NET 4.x version of TextMesh Pro on this version of Unity? The Asset Store version is 1.2.2 and 2017 doesn't have the package manager window (that we can find). We've run into a bug that we are 99% sure is related to the mismatch of our scripting backend and the targeted platform for managed plugins that we're using. Thanks!
     
  7. Stephan_B

    Stephan_B

    Unity Technologies

    Joined:
    Feb 26, 2017
    Posts:
    3,050
    The Unity 2018.3 or newer versions of the TMP package require the new FontEngine which was introduced / included with Unity 2018.3. As such, it is not possible to use these newer versions of the package with previous versions of Unity.
     
  8. WhitethornDigital

    WhitethornDigital

    Joined:
    Aug 12, 2018
    Posts:
    9
    That makes sense! Thanks for the quick response, we appreciate it
     
  9. ProducedByTiG

    ProducedByTiG

    Joined:
    Sep 30, 2018
    Posts:
    1
    Thank you ! after upgrading unity, I was getting the error:

    "Feature `out variable declaration' cannot be used because it is not part of the C# 4.0 language specification"

    and this fixed it !
     
  10. itmahahm73

    itmahahm73

    Joined:
    May 18, 2019
    Posts:
    1
    Thank that is i want,very thanks.......