Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Bug Test Runner stuck in invalid test state

Discussion in 'Testing & Automation' started by chrpetry, Jul 5, 2023.

  1. chrpetry

    chrpetry

    Joined:
    Mar 7, 2018
    Posts:
    65
    Hello,

    it seems I accidentally created an invalid unit test. Shortly after I realized that and fixed it.
    From this moment on I get each frame a recurring error and the TestRunner does not show any tests anymore.
    The error completely prevents me from using the TestRunner:
    Things I tried:

    * Changing the code in the test class
    * Deleting code in the test class
    * Deleting the test class/file
    * Deleting the assembly
    * Deleting library caches
    * (Of course) restarting Unity and my PC
    * Removing Test Framework in PackageManager and reinstalling it
    * Reinstalling Unity

    Somehow I'm at a loss of what to do. I guess there is something in a some global cache that I can't find.

    Does someone have an idea?
     
  2. version23

    version23

    Joined:
    Jul 8, 2013
    Posts:
    1
    Were you able to find a fix for this? I'm running into the exact same issue.
     
  3. chrpetry

    chrpetry

    Joined:
    Mar 7, 2018
    Posts:
    65
    Well, not really.
    I managed to get around for now with a pre test-framework version.
    Edit in manifest.json:

    Code (CSharp):
    1. "com.unity.test-framework": "2.0.1-pre.18",
    At least it works somehow with this.