Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

[Terrain] Paint brush glitches/don't work when Texture Quality not a Full Res

Discussion in '2019.2 Beta' started by Abruzzi, May 27, 2019.

  1. Abruzzi

    Abruzzi

    Joined:
    Feb 6, 2015
    Posts:
    44
    Hi! There is problem with paint texture on terrain, I use 2019.2.0b3 with LWRP 6.7.1. If you set Texture Quality not equals to Full Res then paint texture tool will broke. It don't paint, and also may freeze Editor for a long time(may be forever).
    How to reproduce? Just create terrain, and create a two layers, try to paint it with Full Res in Texture Quality settings in Quality and it should work, after that change settings on another e.g: Half Res and try paint - you can see a problem.

    Sorry for bad spelling, I searched this bug all day in my project it was hard, I'm tired :D
     
    hippocoder likes this.
  2. sylon

    sylon

    Joined:
    Mar 5, 2017
    Posts:
    246
  3. wyattt_

    wyattt_

    Unity Technologies

    Joined:
    May 9, 2018
    Posts:
    424
    I submitted a bug report for this. Will update this post with an Issue Tracker link if that becomes available
     
    Abruzzi and sylon like this.
  4. wyattt_

    wyattt_

    Unity Technologies

    Joined:
    May 9, 2018
    Posts:
    424