Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Terrain is not rendering texture layer after a clean build (CI build)

Discussion in 'World Building' started by masta-yoda, Oct 13, 2020.

  1. masta-yoda

    masta-yoda

    Joined:
    Apr 19, 2020
    Posts:
    28
    I'm using Unity Terrains to set up a simple terrain, it looks like this in the editor, on top of that I'm adding some objects and everything works fine when I build it locally:

    shot_201012_161212.png

    I've verified local build for Android and Windows platforms and everything is rendered correctly:

    OculusScreenshot1602544691.jpeg
    But when I run a build with my CI pipeline, it creates everything from scratch and the terrain is not rendered. I've tried multiple terrain layers, the various texture doesn't matter, the layer is just missing. I can walk on the terrain (so collider is there) but nothing is rendered:

    com.dreamteammobile.BattleArenaVR-20201012-160641.jpg

    The CI build runs on the same dev machine and under the same user account as my local account (basically I'm running a CI agent locally), it pulls the latest sources, imports all the assets (I'm using Unity Accelerator to expedite the process), builds the Library from scratch (compiles shaders, etc) and produced both Android and Windows builds. Both builds are missing the terrain layer as on the screenshot above. Also, if I open the same source code, pulled by CI, in Unity studio and build the project, the terrain layer is rendered correctly so it's related to a clean build using Unity CLI.

    What could be possibly wrong with the CI process and building the source code from scratch?
     
unityunity