Search Unity

Terrain errors when generating lighting?

Discussion in 'Editor & General Support' started by Guest007, Jul 29, 2019.

  1. Guest007

    Guest007

    Joined:
    Jun 14, 2019
    Posts:
    3
    Whenever I try to bake lighting, Unity gets stuck, and the terrain starts displaying multiple errors. "Failed Creating System" is the first one, followed by a very long straight of letters and numbers, and then with each of those, another error that says "instance: Terrain(333.0,0.0,333.0)." The numbers change depending on which terrain chunk it is.

    This has been hanging around in Unity's issue tracker for close to 2 years now, and most people have rated the solutions as not working, period.

    Here are the various things I've tried, pulled from those solutions.

    1. Unchecked the terrain as static. If the terrain is set to static, it will not let Unity bake. If the terrain is set to non-static, then the terrain does not receive baked lights or shadows, which of course, is also unacceptable.

    2. Clearing the GI Cache. I've tried Edit > Preferences > GI Cache > Clean Cache and then restarting Unity. This does not solve the issue.

    These are the main solutions I found while googling around, along with a lot of responses from the devs saying that it would be fixed in a future version. It's been a few years since they first started appearing.