Search Unity

  1. Are you interested in providing feedback directly to Unity teams? Sign up to become a member of Unity Pulse, our new product feedback and research community.
    Dismiss Notice

T-Pose not preserved

Discussion in 'Editor & General Support' started by Johannahe, Feb 19, 2015.

  1. Johannahe

    Johannahe

    Joined:
    Jan 31, 2015
    Posts:
    13
    Hello!

    My model is a T-pose at import.

    I then apply an Avatar Mask and exclude the upper body, head, arms and hands.
    I apply this Avator Mask to the Base Layer in the Animator Controller.

    But when I play a Mechanim animation, the arms / hands go into a zombie like position as shown on the right side.

    Does anybody see why this is so?
     

    Attached Files:

  2. Johannahe

    Johannahe

    Joined:
    Jan 31, 2015
    Posts:
    13
    I am a small step further...

    My model comes with a "Default Take" animation when exported from within Blender. I simply drag the Blender file to my project.
    For some reason, this "Default Take" is taken into account by Mechanim, and therefore my arms get in this zombie like pose.

    Is there a way to have Unity ignore this "Default Take" animation?

    Edit:
    Oh, I think I can simply untick the "Import Animations" checkbox in the "Animations" tab of the model.

    Edit2:
    Hmmm, this does not have any effect. Also deleting "Default Take" does not do really remove the "Default Take" pose from my Mechanim animation. Strange.
     
    Last edited: Feb 19, 2015
unityunity