Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Our response to Improbable’s blog post (and why you can keep working on your SpatialOS game). Read more here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Support for DPI scaling?

Discussion in 'Linux Editor' started by 3vi1, Mar 16, 2016.

  1. 3vi1

    3vi1

    Joined:
    Jan 17, 2016
    Posts:
    6
    The editor doesn't appear to be dpi-aware. When I start it on my 15.6" 3840x2160 laptop screen, it's pretty much illegible.

     
  2. NathanWarden

    NathanWarden

    Joined:
    Oct 4, 2005
    Posts:
    654
    Unity doesn't have hi-dpi support yet except for on the Mac if I'm not mistaken.
     
  3. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    161
    This is more problematic on linux desktops because they don't scale up non-hidpi apps like windows and macs do. And non-hidpi apps end up looking tiny.

    My workaround is to switch to a lower resolution while I'm using Unity. It looks awful but at least I don't need a microscope to see what I'm doing :)

    I'd love to hear what other people do.
     
    3vi1 likes this.
  4. 3vi1

    3vi1

    Joined:
    Jan 17, 2016
    Posts:
    6
    I've still not had the time to seriously play with Unity yet, but my general workaround for dpi-oblivious apps has been to just use Compiz's Enhance Zoom Desktop plugin. I bound the desktop zoom in/out to shift+button4/5 so that I can just zoom in on specific app windows with shift+mousewheel when needed. The only problem with it is the unfortunate bug where it suddenly changes your mouse position when you activate some types of windows like drop-down menus.

    I thought the UE4Editor was also dpi-unaware and unscalable on Linux, but just now discovered that you can scale the interface manually if you go into Window|Developer Tools|Widget Redirector.
     
    spacepluk likes this.
  5. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    161
    Interesting, I'm gonna try it and see how it works for me :)
     
  6. Joseph-Ferano

    Joseph-Ferano

    Joined:
    Jul 18, 2008
    Posts:
    165
    Sorry to bump an old thread, but I'm having this issue as well. I want to run Ubuntu natively and this was a big issue. I'm going to try 3vi1's solution to see if that helps. Is there any updated on this matter? I can also try using a lower resolution I guess.
     
  7. kmare

    kmare

    Joined:
    Jan 30, 2016
    Posts:
    34
    JonSWEDEN likes this.
  8. violeteve42

    violeteve42

    Joined:
    Mar 15, 2017
    Posts:
    2
    I know you posted this a long time ago, so I understand if I don't get a response. What screen resolution do you switch to when working in unity? I am also on a 4k monitor, and this is the first time I've ever tried unity (or any game development for that matter).

     
  9. Eraph

    Eraph

    Joined:
    Aug 15, 2015
    Posts:
    44
    I'm adding my voice to this request, I have a laptop with a 3200x1800 resolution and Unity not scaling is the only thing stopping me migrating from Windows to Linux completely.
    I love the work you guys have done so far though! Keep it up!
     
  10. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    161
    hey @violeteve42, I missed your post. My HiDPI screen is on a 14" laptop and it's QHD+ setting the resolution to 1920x1080 or 1600x900 worked fine for me but not perfect :)
     
  11. Eraph

    Eraph

    Joined:
    Aug 15, 2015
    Posts:
    44
    Here's a workaround for ya. There's an application called run_scaled.
    https://aur.archlinux.org/packages/run_scaled-git/
    This works for me on Manjaro with XFCE, I'd be interested to know if it's available and works the same on other distros.
    Code (CSharp):
    1. run_scaled --scale=2 /usr/bin/unity-editor
     
    spacepluk and JSBmanD like this.
  12. stratosgear

    stratosgear

    Joined:
    Jul 10, 2017
    Posts:
    1
    This works for me under Arch and i3,too (although for my resolution scale=1.5 works better)

    Haven't tried it with any other application, but it seems to be a generic way to improve my hidpi issues. Before I had to hunt around for application specific "magic" commands to trick the application into using another dpi (robomongo, spotify etc)

    Thanks
     
  13. JSBmanD

    JSBmanD

    Joined:
    Oct 19, 2016
    Posts:
    10
    Yeah, that's good solution but not perfect. Because of scaling all is really not sharp. Scale with 1.5.

    Also, on my laptop, performance gone. Scaling isn't solution for some people.
     
    Last edited: Jul 21, 2017
  14. hashashin

    hashashin

    Joined:
    Mar 31, 2014
    Posts:
    21
    What I didn't hear yet is an official answer from Unity. Is this planned? For 2017? 2018? 2020?
    Also, given the number of people "complaining", I am sure someone would be happy to help working on that.
     
  15. unity_iDW4iDGgXl-4tw

    unity_iDW4iDGgXl-4tw

    Joined:
    Mar 15, 2018
    Posts:
    1
    First time user here. Really sad to see this not working out of the box.
     
  16. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    935
    This is planned, but there's no ETA yet, sorry.
     
    kodenkm and amarok-blue like this.
  17. hashashin

    hashashin

    Joined:
    Mar 31, 2014
    Posts:
    21
    Is it anything we could help? Would be happy to use some of my time to help making this a reality.
     
  18. makerender

    makerender

    Joined:
    Sep 3, 2015
    Posts:
    1
    Just wanted to chime in to say that I also would love to see this fixed. I work on a laptop with Ubuntu 16.04 at 2560x1700 resolution and Unity has been unusable since it launched on linux. I've been waiting for this issue to be fixed for a few years now. I really loved using this editor when I was on Windows and now that I'm fully moved over to Linux it's sad to have to delay working with Unity until this is fixed.
     
  19. ChrisMLane

    ChrisMLane

    Joined:
    Jun 17, 2018
    Posts:
    1
    Just came to use the Unity Editor on Linux for the first time and had to do scaling hackery. Hopefully this can be sorted soon!
     
  20. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    935
    Feel free to try the 2018.2 beta series.
     
  21. Fi-Renn

    Fi-Renn

    Joined:
    Jun 19, 2016
    Posts:
    4
    Is there a option in the settings or parameter in the beta? I have installed the 2018.2 beta and didn't found anything...
     
  22. rogper

    rogper

    Joined:
    Sep 17, 2015
    Posts:
    1
    I'm also in 2018.2 and I have a 27" 4K monitor and although it seems to attempt something in the beginning (the screens get's all gray) it then get's back to the normal Dpi with tinny text. I'm waiting for the next version to see if it fixes the problem.