Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Super slow on export for a simple scene with few objects

Discussion in 'Unity 5 Pre-order Beta' started by nintari, Nov 2, 2014.

  1. nintari

    nintari

    Joined:
    Jul 7, 2009
    Posts:
    100
    I left my computer for a bit during export, came back and it is still at the same exact place it was before. "Building level 0: game (Enlighten - Clustering)"

    I don't have much in my scene since it's a test scene. Just a plane, some rocks and some tree models. I did however notice that the lighting for the tree models is messed up (moving around the model to the shadows reveals a bright white reflection that shouldn't be there). The model actually looks better when I move it around as that re-initializes the lighting computations. Very strange.

    And with the rocks, the standard shader initially looked strange as well until I smoothed the lines.

    ...and just as I was typing this... I now see it switched to "Building level 0: game (Enlighten - Visibility)" so I guess it is still exporting after all. But this is far too much time for such a simple scene. I've walked dogs and made coffee since hitting the build button.
     

    Attached Files:

  2. Carpe-Denius

    Carpe-Denius

    Joined:
    May 17, 2013
    Posts:
    842
    How big is your plane?
     
  3. nintari

    nintari

    Joined:
    Jul 7, 2009
    Posts:
    100
    A generic plane dropped in from Unity and scaled 10x10.
     
  4. Carpe-Denius

    Carpe-Denius

    Joined:
    May 17, 2013
    Posts:
    842
    I tried a scene with a similar polycount and the mentioned plane, enlighten takes about one second on export on my mediocre windows-macbook, but it is beta 10 (i don't have 9 installed anymore).
    So, either a problem on your system or something already fixed.
     
  5. willgoldstone

    willgoldstone

    Unity Technologies

    Joined:
    Oct 2, 2006
    Posts:
    794
    Hi, assuming you've quit the process now, but have you submitted this? be good to get a look at it, plus obviously details on your setup?
     
  6. nintari

    nintari

    Joined:
    Jul 7, 2009
    Posts:
    100
    I haven't submitted it, but I'll go ahead and do that just in case something funny is occurring that beta 10 doesn't fix.
     
  7. nintari

    nintari

    Joined:
    Jul 7, 2009
    Posts:
    100
    As I was cleaning up my project to send it to Unity, taking out all the scripts and content that the scene doesn't use, I tried to re-export and it exported quite fast. So it seems like the slowdown in the export process has more to do with all of the files that I'm not using to create the scene rather than the files in the scene itself.

    EDIT: Nevermind-- I just realized what my problem was. I had an additional scene (which was far larger) being compiled with my test scene. (Oops... missed that little check box...) That scene normally doesn't take so long to compile, but it does contain some unsupported features for beta 9 (networking) that would make it fail anyway so it's not a good test case. And I shall go download beta 11 since it is now available...
     
    Last edited: Nov 4, 2014