Search Unity

SUIMONO 2.0 - Interactive Water System

Discussion in 'Assets and Asset Store' started by chingwa, Jan 6, 2015.

  1. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @gecko Sorry, I didn't mean to leave you out on a limb there! I have an idea about a possible way around this but I'll need to edit the 2.0.06 shaders and do some tests. I'll get back to you about this tomorrow.
     
  2. Therian13

    Therian13

    Joined:
    Nov 24, 2013
    Posts:
    64
    Hello chingwa,
    I've come to bother you again. I came across another bug. Whenever I start a scene with the suimono water in, it works great (looks great also, thanks to you!), but whenever I load to another scene, I start getting the console error
    "GUI Window tries to begin rendering while something else has not finished rendering! Either you have a recursive OnGUI rendering, or previous OnGUI did not clean up properly."

    I managed to narrow it down to the Suimono Module Script. The error stops if I have water transparency disabled, under the performance settings. Would you know what may be causing this error by chance?

    The render layers are mixed (about 20 layers in total, with 5 layers disable) and the Use Resolution is on 512. (not sure if this would matter or not).
    I'm using version 2.1.0a.

    Thank you for your help, and I'm sorry for bugging you again!

    **Update**
    I narrowed it more down. the cause of the error is somewhere in the cameraTools script.
     
    Last edited: Oct 27, 2015
  3. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @Therian13 Suimono Version 2.1.1 (preview) should fix this error, which you can test if you're registered on my website.

    This bug seems specific to the cameratools function, just as you've said, and I believe it has to do with the camera trying to render outside of it's expected order. In 2.1.0a what you can try is to go through the object list below and make sure that the camera component of each object is actually enabled...

    - SuimonoModule --> cam_SuimonoTrans
    - SuimonoModule --> cam_SuimonoCaustic
    - SuimonoModule --> cam_SuimonoWake
    - SuimonoModule --> cam_SuimonoNormals
    - SuimonoModule --> cam_SuimonoShoreline
    - SuimonoSurface --> cam_LocalReflections

    Then, you'll need to open up the cameratools.js file and search for lines with the below terms and comment them out...
    "cam.Render();"
    "cam.enabled = false;"

    If you'd like I can send you just the updated cameratools script from 2.1.1, but I haven't tested it directly in version 2.1.0a.
     
  4. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @gecko so my idea about fixing this is not working out. I initially thought I could use the built-in unity tag
    #if UNITY_UV_STARTS_AT_TOP in the shader to detect when the uvs need to be flipped, but after testing this out this morning it simply isn't working as I thought.

    I wonder if perhaps this has to do with different dx9/dx11 settings on your test computers? Do you attempt to use the dx11 feature in your project? I know there are some specific rendering differences between dx9/dx11 in Unity and I'm just trying to brainstorm why this would work on some computers but not all.
     
  5. gecko

    gecko

    Joined:
    Aug 10, 2006
    Posts:
    2,042
    I'm on a Mac and not very familiar with dx9/11. I've got the Mgr set to Unity Pro (not DX11 -- but Suimono will still use DX on Windows, right?). I could try to gather info about the computers that have the problem in Forward Rendering (that is, those that have the weird reflection when "Use UV Reversal" is toggled on. What kind of info would be useful?
     
  6. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    If you're on Mac then that answers the dx question, as dx11 isn't available through Unity on Mac. I guess things to check for would be platform (mac/pc and OS version) and graphics card (radeon/nvidia and version). In addition if it's possible to show screenshot of a similar scene when it's working correct and when it's not this might help track down any bugs.

    The latest version of Suimono will automatically pick dx9 or dx11 when available, but older Unity4 versions will not, so if it's set to Unity Pro on the dev side it isn't going to upgrade itself to Unity Pro DX11 on PC, unfortunately.
     
  7. gecko

    gecko

    Joined:
    Aug 10, 2006
    Posts:
    2,042
  8. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Thanks for the video! And yes that's about what I expected. Just wanted to confirm we're talking about the same thing :)
     
  9. gecko

    gecko

    Joined:
    Aug 10, 2006
    Posts:
    2,042
    We've seen this problem on Windows computers with these graphics cards:
    -Intel Mobile Intel 4 Series Express Chipset Family
    -Intel HD Graphics Family
    -128MB PCI Express™ x16 ATI Radeon X300 SE HyperMemory
     
  10. Therian13

    Therian13

    Joined:
    Nov 24, 2013
    Posts:
    64
    @chingwa
    It worked. :)
    I don't have any of the cam_objects you mentioned except the SuimonoTrans.
    I commented out the two lines, and just told it to turn the camera on at Start. Worked like a charm!
    Thank you for your help!
     
  11. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
  12. Therian13

    Therian13

    Joined:
    Nov 24, 2013
    Posts:
    64
    @chingwa,

    maybe a false alarm....
    found a new bug maybe. If I dive deep underwater (where the underwater fog covers the top of the water), and look up, the project freezes. Debug log doesn't say anything. Its almost like it gets caught in some sort of loop.

    I will test it some more to see if it is because of the water...
     
  13. Therian13

    Therian13

    Joined:
    Nov 24, 2013
    Posts:
    64
    A bit more digging shows that it only occurs when the Suimono_reflectionMirror script is on.

    **update**
    Yep, its something to do with the reflection. If I disable it, it doesn't freeze anymore, but once it's turned back on. it freezes up again, with Unity running at 99% CPU.
     
    Last edited: Oct 29, 2015
  14. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @Therian13 I have a feeling this might not be an issue for you in 2.1.1, as the underwater rendering and reflections have been rewritten. I've tried to recreate this on my end in 2.1.0 but it doesn't seem to be a problem here. Care to give 2.1.1 (Preview) a try?
     
  15. Therian13

    Therian13

    Joined:
    Nov 24, 2013
    Posts:
    64
    @chingwa
    I can wait until its released. I just turned off the reflection, but the water still looks pretty good. I can just turn it back on in a later update. Not sure why it started doing it though. It used to run smoothly until that GUI error started happening. It could just be Unity being a pain again though.
    But thank you though. If you weren't getting the error, it was probably just my game then.
     
  16. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Hello All! I just wanted to leave a note saying that the final version of 2.1.1 will be ready soon, There are just a couple more issues I need to work out and implement.

    In addition to this I've made some additional progress on a few features that have been on my roadmap for over a year... The screenshot below shows the upcoming persistent underwater view. The underwater rendering is now rendered through a below-surface mask, which not only allows smoother transitions between above water and below water, but also allows a split-screen effect like below.

    I'm really excited to finally get this implemented, and I hope to have it in everyone's hands soon!

    Update 4/9/2016 - This feature did not make it into version 2.1.1, but I'm still considering it for a future update.

     
    Last edited: Apr 9, 2016
    Shawn67 and llJIMBOBll like this.
  17. mwituni

    mwituni

    Joined:
    Jan 15, 2015
    Posts:
    345
    Hi Chingwa,

    Haven't used it a while.
    Just checking back re performance ... I assume the LOD's you mentioned are in and working?

    Also ... its pretty important to have auto LOD switching for when the user camera moves a distance from water - Hows that going? I assume its quite tricky as infinite water is everywhere (underground too) ... but I guess you have the depth info to see where nearest visible water is.

    This should also control sound fadeout etc, and as a final LOD completely disable water - maybe just render as a flat surface with static texture in similar colors.

    Also the auto LOD would need to disable and re-enable various performance-affecting functions (some of which the dev may have disabled so they should never be re-enabled etc).

    Yes - Probably the LITE option could be handled by a lower LOD ... so if LOD is enabled, one would need to be able to specify which is the highest LOD to use in a scene (in order to keep resource usage down).
     
  18. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @mwituni Yes, the LOD's are in and working now. You can select between a few different LOD levels, however there is not any auto-LOD switching currently. It is a bit more tricky to do this with water as compared to a typical game object since the water can be at various scales in your scene.

    I think what you're suggesting may better be described as an overall performance slider (though I do agree that some functions can be turned off at a distance). I've been considering working on this for a future update but haven't done any development yet. I'll look into this some more soon :)
     
    Shawn67 likes this.
  19. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    A NOTE ABOUT UNITY 5.3:
    Suimono 2.1.0a (the current version available from the asset store) reports rendering errors with Unity's latest 5.3 update. The Suimono 2.1.1 preview version available from my website does not have these issues, and I hope to have the final version of 2.1.1 available on the Asset Store soon. In the meantime I highly recommend everyone to upgrade to the preview version by registering on my website here: http://www.tanukidigital.com/suimono/index.php?register=1
     
    llJIMBOBll likes this.
  20. llJIMBOBll

    llJIMBOBll

    Joined:
    Aug 23, 2014
    Posts:
    558
    hi, im trying to make reflections work with oclussion culling, if i have it in my scene the reflections dont render right and only appear at certain camera angles, if i turn it off its ok... but with unity water u can simply make the camera not render OC and the water works fine with reflections and OC... i tryed with suimono disabled the oc from the camera cam_SuimonoTrans but it doesnt work.. any suggestions? thanx
     
  21. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Hi @llJIMBOBll The reflection settings currently inherit most of the settings from your main camera, including occlusion culling. Are you saying that an object that is occluded from your main camera is being occluded from your reflections, when they shouldn't be? I have a few things I can test in order to troubleshoot this... Send me an email at konnichiwa[at]tanukidigital.com and I may be able to send you a test file. A screenshot or short video of what you're experiencing might be useful too :)
     
  22. krisuman

    krisuman

    Joined:
    Jun 29, 2015
    Posts:
    2
    Hello,
    when i use Suimono i got this error all the time:

    Even when i create completly new project with Suimono only.
     
  23. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Hi Krisuman,
    I've responded to your question on my forum here: http://tanukidigital.com/forum/index.php?topic=702.0
    Best to keep these questions/answers in one place. Please take a look and let me know there if you still have issues.

    EDIT: For anyone else who is reading this, the above errors seem to be showing up in Unity 5.3. However the next update has already addressed this error and registered customers can download a preview of this update with this and many other improvements.
     
    Last edited: Jan 15, 2016
  24. EternalAmbiguity

    EternalAmbiguity

    Joined:
    Dec 27, 2014
    Posts:
    2,142
    I was having the same error as krisuman, so I just went to your site and downloaded 2.1.1.

    On one hand, I don't have that error and it looks gorgeous. On the other, I'm getting this:
    IsFinite(outDistanceForSort)
    which I suspect is the camera. I also noticed that at the edges of my screen camera, water transparency further out is visible, while it is not visible from head-on. See the attached image:
    Unity 2016-01-15 00-34-09-95.png
    There on both sides. Now, I did change the water transparency distance in the "Advanced Water Settings" on the Module GameObject. Returning it to its original value of 1000? fixes the issue. But how would I decrease that distance without the glitch?

    Finally, performance is really, REALLY slow. You can see in that image that my FPS is around 25. If I disable the Module and Surface GameObjects, I get an FPS fluctuation of either 165-220 (according to FRAPS) or 250-420 (Unity). That's an incredible drop in speed. The only things I did to Suimono were to drag and drop the two prefabs, change the water transparency distance, and change the water type to "Calm Carribean Blue."

    Do you know why that is happening? Is it simply because 2.1.1 isn't finished or something?
     
  25. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @EternalAmbiguity The first thing I would do is go to your water surface and either turn the tessellation settings down, or turn them off. The default setting in the preview release is way too high for most use-cases and this is often a large cause of FPS issues. Try setting the "tessellation factor" setting to 8 or lower. You can find some additional tips on optimization here: http://tanukidigital.com/forum/index.php?topic=711.msg2423#msg2423

    The distance rendering issue in your screenshot can be fixed by enlarging the 'water transparency distance' on the Suimono_Module object. This is here to maximize performance, so this should only be set as high as you need it. In many cases the water absorption/fog settings would cover up the lack of distant transparency, but in your case if you want the water to be clear in the distance then yes you'll need to give it a larger distance setting.

    In addition to the above, there is a bug in the preview version that prevents proper water normals from rendering in some cases. From the look of your screenshot I suspect this might be happening for your scene. This will of course be fixed in the final release but for now you can go to your suimono_module-->cam_SuimonoNormals object and uncheck the 'HDR' setting on the camera component, which should address this.

    As for the IsFinite error... I believe this is an error specific to Unity 5.3.1, and is related to particle systems. Specifically, it's a bug in Unity reporting a particle system being accessed from code with a 0 particle count. You can try downloading the 5.3.1p1 patch release, as Unity says that should fix this error: http://forum.unity3d.com/threads/un...d-aabb-result-isfinite-d.374926/#post-2433181

    You can get patch releases here: https://unity3d.com/unity/qa/patch-releases
     
  26. EternalAmbiguity

    EternalAmbiguity

    Joined:
    Dec 27, 2014
    Posts:
    2,142
    I'm not at home so I'm unable to test out your first couple of suggestions, but I will say that for the "IsFinite" error I am using the patch release. I actually had that error with a bunch of other unrelated stuff and then got the patch release as a result. I'll try the suggestions when I get the chance. Thanks for the help.
     
  27. kburkhart84

    kburkhart84

    Joined:
    Apr 28, 2012
    Posts:
    751
    Just wanted to post to say this asset looks great, and I bought it, even though I can't actually use it on my current project. I also bought the Tenkoku sky system, so now when I get to a project that can use them I'm ready to roll.
     
  28. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
  29. llJIMBOBll

    llJIMBOBll

    Joined:
    Aug 23, 2014
    Posts:
    558
    Edited! Not relevant
     
    Last edited: Feb 4, 2016
  30. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    This sounds like a setup issue, there is no reason it should be disabling your image effects or weapons camera. The fps hit can be managed by adjusting some settings according to how heavy the fps drop is in your scene (first thing would be to lower or disable tessellation).

    If you can give me more info about what's happening then I'm sure with a bit of back and forth it can be made to run in your project quite nicely.
     
    Last edited: Feb 4, 2016
  31. llJIMBOBll

    llJIMBOBll

    Joined:
    Aug 23, 2014
    Posts:
    558
    Edited Not relevant

    edit.. ok disabling some cameras for trans, caustics, seems to enable image effects back and i can see the water, but shows some artifacts on water surface

    edit. Wow, I think I should start off by saying Sorry! I now have managed to get it to work, FYI disabling cam_SuimonoCaustic seemed to make everything work again. Thank you & Sorry Jimbob
     
    Last edited: Feb 4, 2016
  32. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    No Problem Jimbob, I'm just glad things are working as they should. If you run into any more issues, or if you'd like to go further into what problems you were having then just let me know.
     
  33. llJIMBOBll

    llJIMBOBll

    Joined:
    Aug 23, 2014
    Posts:
    558
    Hi, I found something interesting, if i disable caustics and run scene nothing will render, but if i disable the cam then it will.. this also does the same for transparent, I disabled it or set the slider to the end, saved preset and ran scene and everything wasn't rendering again, but after I disabled the trans cam it worked. Thanx Man new water is Awsome looking & doesn't really affect fps at least from my scene's anyway
     
  34. mwituni

    mwituni

    Joined:
    Jan 15, 2015
    Posts:
    345
    Hi,
    Do you have any code examples for controlling the sound (the ocean waves sound) volume from C# ?

    ie. I want to fade the sound out and back (probably based on triggers) - like when entering a ship interior etc.

    And when did you say the C# version would arrive?! :)
     
  35. Shawn67

    Shawn67

    Joined:
    Jan 2, 2014
    Posts:
    2,196
    I asked about the sounds a while back and what I understood was there wasn't a really good way to control the sounds directly in Suimono. I think Justin mentioning maybe working on a way to deal with the sounds better. My question was regarding fading the sound as you go inland on an island. If that is the case, I assume you would disable sounds and then put them in whatever audio controller you are using to manage sounds for the scene.

    I'd love to chime in on the plea for C# as well. It sounded like a port was something you planned on working on after getting 2.0 released last year. Would really love to replace the only non-C# script in my workspace. :p
     
    chingwa and mwituni like this.
  36. mwituni

    mwituni

    Joined:
    Jan 15, 2015
    Posts:
    345
    Yes exactly ... the water is under the entire island and you're forced to listen to the waves all over.

    I'm surprised there isn't some sort of solution for it as it obviously affects everyone using infinite water ... which must be most customers.

    Maybe best is to just add methods that can be called ... fadeSound(targetVolume, fadeTime) ... specially if it's in a C# unit!
     
    chingwa and Shawn67 like this.
  37. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Hi guys, yes I do understand the need for this as the current sound solution through Suimono is either on or off. The problem with doing this directly in suimono is that the water system doesn't actually know where your shorelines are. I can't really think of a feasible way for suimono to detect this information, considering it would need to be useable in a variety of environments/projects for which I have no control over.

    The best course of action currently, is to disable the abovewater sound in suimono, by going to Suimono_Module-->_sound_effects and removing the 'abovewater sound', then add your own Unity AudioSource objects (using the same abovewater audio file if you like) around your scene near to your shorelines. This allows unity to automatically adjust the volume levels as you advance/retreat on the audio sources, without any coding on your end.

    Alternatively you can adjust the current abovewater audio through code (C# or JS) if you like... When the scene is playing, do a search for an object called 'Underwater Sound'. You can then access the 'audiosource' component on this object and adjust the volume according to how you see fit. The audio clip on this object will automatically switch between an above-water clip and a below-water clip accordingly. This object is instantiated when Suimono first runs, so it won't be findable while the scene is not playing.

    A C# conversion of Suimono is still on my to-do list, and I plan to start looking at this soon.
     
  38. Nick-Carver

    Nick-Carver

    Joined:
    Feb 20, 2016
    Posts:
    8
    Apologies if this question has been answered before but I'm wondering if it's possible to enlarge the size of the surface being deformed? My project is using objects at meter scale and so when I set a camera to the correct distance for that scale, I can see the deformation of the water surface constantly popping in in front of me. Is there a setting to increase the distance of the deformation, or do I need to resize my scene to a smaller scale (cm for instance)?

    I'm really enjoying using Suimono, by the way. It's perfect for the game I am currently prototyping.
     
  39. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Hi Nick,

    Suimono assumes you're using the default scale (1meter) in Unity, though I don't know if the scale really would matter in how it performs or renders. You can select a few different lod sizes in the general settings tab, or you can enlarge/reduce the amount of tessellation that gets performed on the surface (assuming you're using dx11?).

    If you can post a screenshot (or email it to me.. konnichiwa[at]tanukidigital.com) I may be able to tell more about what's happening in your scene.
     
  40. Nick-Carver

    Nick-Carver

    Joined:
    Feb 20, 2016
    Posts:
    8
    Thanks for the prompt reply.

    I think the issue is being caused by a combination of factors: 1. Having the camera pulled way out from the player's vehicle, and 2. Having the vehicle moving at a much faster rate than the default speed used in the Suimono demo. I looked through the Suimono documentation again and managed to fix the issue by increasing the ocean size. I guess I was seeing the transition from high res to low res ocean? I still am noticing some other issues in my project but these might be due to settings I adjusted from the defaults. I'm going to import a 'clean' version of Suimono into my project and start again from there again. Will let you know, and send footage, if I'm still having problems.


    Thanks!
     
  41. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Just a note that if anyone is experienceing "isInfinite" errors in their console with Suimono, I have a small patch file that fixes this. PM me or send me an email and I'll get it to those who need it.
     
  42. mwituni

    mwituni

    Joined:
    Jan 15, 2015
    Posts:
    345
    Is anyone else having buoyancy issues with 2.1.0a ?
    My items just sink. Just a simple mesh with one buoyancy component.
    Apparently setup (parameters) is correct.

    I'm on Unity 5.2.0f3, but that shouldn't matter.

    Thx
     
  43. mwituni

    mwituni

    Joined:
    Jan 15, 2015
    Posts:
    345
    Also, where is the DepthMask?

    My boats had a DepthMask to hide water in bottom of hull in older Suimono, but I don't see it in new version.

    thx
     
  44. rpg_gamer

    rpg_gamer

    Joined:
    Nov 28, 2012
    Posts:
    214
    hi there, trying to track down an error I get every frame :

    Material doesn't have a texture property '_FoamOverlay'
    UnityEngine.Material:SetTextureScale(String, Vector2)
    SuimonoObject:Recalculate() (at Assets/SUIMONO - WATER SYSTEM 2/SCRIPTS/SuimonoObject.js:1595)
    SuimonoObject:LateUpdate() (at Assets/SUIMONO - WATER SYSTEM 2/SCRIPTS/SuimonoObject.js:848)
     
  45. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @rpg_gamer this is an issue with Unity 5.3+, you'll need to upgrade to the latest version of Suimono (2.1.1 preview) to fix this. The latest is currently only available from my website. You'll need to register with your Asset Store order number in order to get access to the downloads page... http://www.tanukidigital.com/suimono/index.php?register=1
     
  46. knotFF

    knotFF

    Joined:
    Apr 13, 2013
    Posts:
    66
    Two issues with Unity 5.4.B10 - Suimono 2.1.1 (as of today):

    Code (CSharp):
    1. NullReferenceException: Object reference not set to an instance of an object
    2. SuimonoModule.Suimono_CheckCamera () (at Assets/SUIMONO - WATER SYSTEM 2/SCRIPTS/SuimonoModule.js:1088)
    3. SuimonoModule.Start () (at Assets/SUIMONO - WATER SYSTEM 2/SCRIPTS/SuimonoModule.js:331)
    Code (CSharp):
    1. UnityException: Load is not allowed to be called from a MonoBehaviour constructor, call it in Awake or Start instead. Called from script 'suimono_module_editor' on game object ''.
    2. See "Script Serialization" page in the Unity Manual for further details.
    3. UnityEngine.Resources.Load (System.String path) (at /Users/builduser/buildslave/unity/build/artifacts/generated/common/runtime/ResourcesBindings.gen.cs:53)
    4. suimono_module_editor..ctor () (at Assets/SUIMONO - WATER SYSTEM 2/EDITOR/suimono_module_editor.js:19)
     
  47. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    @FF1878 Thanks for posting these! I've noticed a few other issues in the latest Unity beta as well. I don't typically support the Unity beta releases as they often have too many changes and systems in flux to keep up with, but I am certainly keeping my eyes on it and logging any issues that need to be addressed.
     
  48. Zaphier

    Zaphier

    Joined:
    Jul 20, 2015
    Posts:
    2
    Any ETA for 2.1.1 or higher? It`s over a half year since last update.
     
  49. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
  50. chingwa

    chingwa

    Joined:
    Dec 4, 2009
    Posts:
    3,444
    Hello All,

    Suimono version 2.1.1 has been a long time coming, but is now finally available for download.

    Download Here: http://www.tanukidigital.com/download
    This version is now also available on the Asset store here: https://www.assetstore.unity3d.com/en/#!/content/4387 as well as the Unity Download Manager for those who've already purchased.

    I know many of you have been waiting a long time for this update and I apologize for the burdensome delays. There have been a number of changes in the final version of 2.1.1, most of them behind the scenes, to help insure that Suimono runs as smoothly as possible.

    New Demo Scene
    in addition to the advanced demo scene that has shipped with Suimono since version 2.0, there is also now a Buoyancy Demo scene which shows an example of a single buoyant object in variable lighting and wave factor settings. You can see it running as a webplayer here: http://www.tanukidigital.com/suimono/demo2.0

    What's New
    You'll notice some updates to wave and foam rendering, improvements to underwater rendering, Some additional performance and useability settings, and much more. Default settings have been adjusted so Suimono should have better performance out-of-the-box,

    Going Forward
    I'd like to thank everyone for their continued support and patience during this update! I have been experimenting with other major features (such as improved river support and split above/below view) but have yet to decide if/when they will make it into an official release. There a number of small incremental features that I would like to integrate soon (such as rain ripples... and of course C#!). I expect future updates to be both smaller and to follow on a more timely basis.

    A Note About Unity 5.4 Beta
    I've incorporated a number of fixes into this release that should allow a better experience in the Unity 5.4 beta. There are still some issues that I haven't found an explanation for yet, probably due to a bug with the beta itself. I don't officially support updates for Unity beta releases since they are often filled with bugs and other compatibility issues, but I am tracking any problems that arise and will make sure Suimono is as compatible as possible,

    As always, let me know if you have problems/questions/feedback etc, either by email or on the forums!

    All the best,
    Justin Kellis
    Tanuki Digital



    UPDATE: 4/9/2016 - Suimono Version 2.1.1
    ------------------------------------------------------------------------------------------------
    WHAT'S NEW:
    (new since 2.1.1 preview)
    - Improved default performance settings.
    - Added new 'Camera Mode' setting which switches between auto select and manual camera designation.
    - Added slots to enable/disable underwater and above-water sounds from module UI.
    - Added attribute to enable/disable advanced caustic effects (comes with performance cost when enabled).
    - Added reflection blur function.
    - Added underwater blur function.
    - Added underwater darkening setting which shifts the brightness underwater as you get deeper.
    - Added Gaia GX compatibility.

    (new since 2.1.0a)
    - Completely rewritten water shader and wave effects.
    - Water surface waves can now be modulated based on Beaufort wave scale (0-12), from still to calm to stormy.
    - New Underwater Effect, now contained in an Image Effect component that get's added to camera.
    - Improved Edge Blending effects.
    - New Caustic system with better performance and more realistic rendering.
    - ReWritten Preset system. Each preset is now contained within it's own file, which can be backed up (and shared!) as needed.
    - New Shoreline system. Setting up where you want shoreline waves and foam to be generated is now customizable with the new 'ShorelineObject' prefab.
    - New Integrated normals displacement/refraction effects, most notably on the ripple effect.
    - Improved foam rendering. Edge foam now blends properly with shoreline and other objects and renders into the distance.
    - Improved Buoyancy and GetHeight() performance, allowing more concurrent function calls without dragging down system performance.
    - Graphics auto-switching. Dx9 and Dx11 versions are now determined automatically and should switch based on the computer and Unity settings.
    - Rendering Parity between Forward/Deferred/Legacy Deferred.

    CHANGES:
    - Adjusted water surface wave and reflection calculations.
    - screen drop and fade effects now combine properly against scene backdrop (skyboxes etc).
    - Screen drop and fade effects now moved to camera effect.
    - Improved height-wave foam rendering.

    BUG FIXES:
    - Fixed underwater debris rendering.
    - Fixed jitter/shift errors in infinite ocean mode.
    - Fixed errors with reflection fallback generation (can fallback to color, cubemap, or skybox).
    - Various code changes for Unity 5.4 beta version.
     
    Last edited: Apr 12, 2016
    Voodoo_ZA likes this.