I want to suggest renaming GameObjects created from menu. In Release2, with hierarchy window 'create' > '2D Object' > 'Tile Map', TileMap GameObject with Grid Component and Layer GameObject with TileMap and TileMapRenderer Component are created. I think this names are a little confusing for new TileMap users. The reason why the names are confusing is that TileMap GameObject does't have TileMap component and GameObject that has TileMap component is not named as TileMap. How about rename them? For example, TileGrid GameObject with Grid Component and TileMap GameObject with TileMap and TileMapRenderer. Are there any reasons for the current names? ps. I wrote TileMap article in Japanese, but it was a little hard to describe the GameObject name and Component releations.