Search Unity

  1. Calling all beginners! Join the FPS Beginners Mods Challenge until December 13.
    Dismiss Notice
  2. It's Cyber Week at the Asset Store!
    Dismiss Notice

Streaming audio: Error: Cannot create FMOD::Sound instance

Discussion in 'Scripting' started by lascoin, Sep 19, 2016.

  1. lascoin

    lascoin

    Joined:
    Jan 25, 2013
    Posts:
    16
    Hi everyone!

    We are experiencing an issue related to streaming audio files and playing these using the unity WWW class. Every time we stream an audio clip and play it, this error appears in the console:

    After googling around a bit, this seems to be quite a frequent error that many have been experiencing to and from different Unity versions. In one of these threads, there is a link to an issue on the Unity forums:

    https://issuetracker.unity3d.com/issues/fmod-sound-instance-for-resource-error

    Which has been marked as resolved. However if you read the top comment, it appears as though this issue has been reintroduced in Unity 5.4.0f3 which is our current Unity version.

    In another thread, http://forum.unity3d.com/threads/what-format-is-needed-to-stream-audio-on-windows-10.368670/ the answer has been to use the "file:///" prefix to the path used to load using the WWW class which I've also tried but to no avail.

    So has anyone experienced this issue and been able to resolve it using Unity 5.4.0f3 or newer versions? Is this a known issue Unity developers? Seeing as the issue is marked as resolved on the bug tracker but it's still present.

    Thanks!
     
  2. tistik

    tistik

    Joined:
    Mar 15, 2012
    Posts:
    4
    Hi there,

    We are still experiencing this issue in unity 5.5 with WWW class audio streaming. On iOS Android and PC (not tested elsewhere) the first seconds of the sound cannot be heard and the same error is thrown.

    Has someone found a workaround ? Are there other people having this issue ?

    Thanks
     
    Artyom-Abgaryan likes this.