Search Unity

Strange issue with beta 8 post processing

Discussion in '2021.1 Beta' started by castor76, Feb 26, 2021.

  1. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
    There is some strange post processing issue with URP 2Drenderer for recent beta 8 version.

    The whole screen (except UI) becomes just black and there are some strange flicking going on even with post processing turned off.

    The same project does work fine with previous beta 7. Reimporting the project into older beta 7 works. Changing to beta 8 becomes a problem.

    Anyone with the same problem?
     
  2. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    2,492
    Hi @castor76,

    Would it be possible for you to submit a bug report with the project or another reproducible attached to it so we could have a look?
     
  3. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
    I have submitted bug report : 1318500
     
    LeonhardP likes this.
  4. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
  5. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
    I hope the fix lands on b9, but seeing that the b9 also has the same bug according to the issuetracker, I guess I have to wait till b10 or is there still a hope for a fix to be landed on b9? (since b9 has not yet been publicly released.)
     
  6. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    2,492
    Thanks for the bug report and for sharing the information here @castor76. This is a high priority issue and currently being investigated. We don't have an ETA for a fix yet. However, both b9 and b10 have already been cut and are currently tested internally before being released, so the earliest possible version with a fix would be b11 if the issue ends up being on the Editor side. It's a different story in case the fix will land on the URP package side.

    Once we have a fix, the status here will change:
     
  7. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
    Ok, so I can confirm that after testing b11, the bug is still present. Cross my finger for b12 then..

    But the issue tracker seems to tell us that the fix is for the URP package 12, so I wonder when v12 be out..... I mean this could be in months?
     
    Last edited: Mar 13, 2021
  8. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
    Fix for the issue is set to be for URP 12 and 11. But is there any eta on it?
     
  9. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    2,492
    The fix was merged to the 2021.1 staging branch 11 days ago so it should be in the next release.
     
  10. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
    Thanks B13 it is then!
     
  11. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    2,492
    Sorry, I should have made this clearer. The fix landed in the SRP repository so it will be in the next release of the 11.x package for URP.
     
  12. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    2,111
    Oh. I see. I wonder when URP package update happens... as it does not seem to happen as often as beta
     
unityunity