Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Strange colors reflection but only in build, not in editor

Discussion in 'General Graphics' started by Firlefanz73, Sep 13, 2017.

  1. Firlefanz73

    Firlefanz73

    Joined:
    Apr 2, 2015
    Posts:
    874
    Hello everybody,

    I am using Unity 2017.1.1f1

    maybe somebody can give me clue:

    My game Looks fine in Editor:


    I am Building x86_x64 with Gamma. Now same Scene Looks like this:


    I set Gamma to linear in the Player Settings. Then I see strange black Areas wandering around when I move the camera instead of theses colorfull ones. I think it is the somehow lightened Areas... and there different shaders most of them Standard opaque.

    I had postprocessing v1 attached with some effects and removed it, that did not help.

    Turned on and off HDR also did not help.

    It never happens in the Editor, Looks perfect there!

    Any clue how to get rid of this strange Problem? Thanks a lot!
     
  2. Firlefanz73

    Firlefanz73

    Joined:
    Apr 2, 2015
    Posts:
    874
    I am pretty sure it has something to do with the reflections. I also tried different Scene light Settings but did not help.
    But when I started the build with the lowest Quality Settings the Problem was gone.... any idea please?
     
  3. Firlefanz73

    Firlefanz73

    Joined:
    Apr 2, 2015
    Posts:
    874
    Found the solution, it was a Problem with the global reflection, thanks for your interest!
     
  4. Orthac

    Orthac

    Joined:
    Aug 9, 2017
    Posts:
    2
    i have the same problem. what was the solution in detail?
     
  5. Firlefanz73

    Firlefanz73

    Joined:
    Apr 2, 2015
    Posts:
    874
    Turning on HDR on a Non-HDR System might be a Problem.
    I had a Problem between Enviro and Postprocessing stack both v1 or v2 and Global Reflection.

    I do not use Postprocessing anymore, I only wanted DOF Blur and found a better way (or at least for me better way).