Search Unity

"Stereo Display (non head-mounted)": Poor 3D effect

Discussion in 'AR/VR (XR) Discussion' started by SimRuJ, Dec 4, 2018.

  1. SimRuJ


    Apr 7, 2016
    The main monitor of the PC (Win 10) I'm running Unity (2017.3.1f1) on doesn't support nVidia 3D Vision and I also don't own a VR headset but I still wanted to test the 3D effect with Anaglyph 3D (red-cyan), so I enabled "Stereo Display (non head-mounted)" (in Edit - Project Settings - Player - XR Settings) and disabled all the other SDKs.

    In a build with "Stereo 3D" in the "Configuration" window checked (the Game View in Unity doesn't support this XR setting) you can see the two colors at the edges of the panel (scroll bar on the right, button on the left):

    The overall 3D effect is really poor though - especially in the actual game scene everything's simply yellow-ish and there's no noticeable 3D effect (apart from the menus).

    If I uncheck "Virtual Reality Supported" in Unity and only leave nVidia's stereoscopic 3D (also anaglyph) enabled the 3D effect is great:

    Scene layout:
    - Player
    -- Main camera (doesn't see UI)
    --- Camera (only sees UI)
    The "main menu" scene doesn't use a "player" object but otherwise it's the same.

    Stereo Separation: 0,022
    Stereo Convergence: 10
    Target Eye: Both
    I'm using these default settings for both scenes. I already tried putting them to 2 and 1000 but no change.

    Do you need any specific settings to get the 3D effect to work properly with just the "Stereo Display (non head-mounted)" setting? Is this even what it's used for?