Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Start project with the relevant version of Unity rather than default prefered version

Discussion in 'Unity Hub' started by crener, Mar 21, 2018.

  1. crener

    crener

    Joined:
    Aug 29, 2015
    Posts:
    27
    I don't know if it's already planned but I'd like to have Unity open the version of unity that was being used the last time the project was open. Right now when I click the name of a project it opens my prefered version which isn't always the version of the project which means that Unity does all sorts of stuff, like changing code, which I'd rather avoid.

    If the version that the project uses isn't installed maybe show a box with the option to either download or use prefered version?



    Again, I don't really know if this has been suggested or is planned already, sorry if this is spammy... :)
     
  2. Din0m1te

    Din0m1te

    Joined:
    Sep 9, 2015
    Posts:
    30
    Well... The hub actually works exactly the way you describe it.

    - If project version available it will launch using that version.
    - If not, it will show a popup and aks you to download the right version or use the preferred version.

    Maybe you found a bug and behaves differently for you.
     
  3. crener

    crener

    Joined:
    Aug 29, 2015
    Posts:
    27
    Huh, well I started a project which is made in 17.1 and it started with 17.3
     
unityunity