Search Unity

Standard Terrain Brushes ALWAYS terracing (but gaia stamps etc don't)

Discussion in 'World Building' started by yonson_chappers, Jan 28, 2019.

  1. yonson_chappers

    yonson_chappers

    Joined:
    Feb 6, 2017
    Posts:
    16
    I've been having a really strange error with the new terrain setup since 2018.3. Basically, all the terrain stamps produce 'terracing' whenever I use them - not even when actually drawing them but once I click 'save' on the scene.

    I've seen lots of posts about it being various settings on my terrain etc, but it can't be this because when I'm using Gaia Stamps etc then its fine, so it is something to do with the terrain brushes. I've seen stuff in the new blog about how R16 brushes fixes this, but in the terrain blog it was only a quick comment but no information about how to actually switch a brush over to R16. Can you tell me what I need to do to get the terrain brushes working normally (i.e. smoothing etc as per terrain setting and not terracing)?
    I've included a screen shot of what I mean - the background is a gaia stamp - everything is fine. The foreground hill is the standard terrain brush to build a hill, and you can see the effect - terracing. Really odd problem hopefully its just a setting that I don't know about, or is this a bug?

    Thanks

    upload_2019-1-28_16-3-11.png
     
  2. ChrisTchou

    ChrisTchou

    Unity Technologies

    Joined:
    Apr 26, 2017
    Posts:
    63
    Yes, this is a bug. (The OpenGL implementation was copying through an 8-bit texture).
    It was fixed in 2019.1a12; we're looking at backporting the fix to 2018.3.
     
    Rowlan likes this.
  3. Mashine707

    Mashine707

    Joined:
    Jan 18, 2017
    Posts:
    2
    I have the same error. Tell me, will this be corrected in 2018? I have version 2018.3.5