Search Unity

Sprites looking pixelated

Discussion in 'Editor & General Support' started by Deleted User, May 3, 2014.

  1. Deleted User

    Deleted User

    Guest

    When i raise the orthographic size all of the edges on my sprites look pixelated.

    Are there some settings i don't know about to fix this?

    I wanted to create zoom-out for my game so is this the way to go about it?

    Or should i create a separate sprite for every "zoom level"?

    Thanks.
     
  2. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    28,002
    if its set to point filtering, this is normal. Otherwise ensure that you disable mip maps, as that may be a cause as well. Just tinker with texture settings.
     
  3. Dave-xP

    Dave-xP

    Joined:
    Nov 8, 2013
    Posts:
    106
    how pixelated ?
    -> choose one -> $howPixelated.png
     
  4. Deleted User

    Deleted User

    Guest

    It's set to bilinear, i tried setting it to trilinear but the result is same.

    And i tried but i couldn't find the setting to turn off mip maps.

    This is at orthographic size 5: http://i.gyazo.com/41afc590a07c18103adfc985d106d330.png
    This is at orthographic size 25: http://i.gyazo.com/ac9fb222fbe9a8c2936241a44c6c9304.png

    The edges look horrible.
     
  5. Dave-xP

    Dave-xP

    Joined:
    Nov 8, 2013
    Posts:
    106
    you could use a blur effect
    and set the blur level equal to the zoom level
     
  6. Deleted User

    Deleted User

    Guest

    I googled the blur effect and found out it's unity pro only.

    Since i just recently started using unity and will not be getting pro for some time, is it possible to achieve this effect in unity free?

    It doesn't have to be top-notch, just for the time being that i don't have to look at those ugly edges.
     
  7. Dave-xP

    Dave-xP

    Joined:
    Nov 8, 2013
    Posts:
    106
  8. Deleted User

    Deleted User

    Guest

    Thanks, i'll try that.
     
  9. smd863

    smd863

    Joined:
    Jan 26, 2014
    Posts:
    292
    That's what mipmaps are. I'm 99% sure Hippocoder meant to check to make sure you didn't disable mipmaps. This problem is exactly why mipmaps were invented (read the Wikipedia article about them). The option should be in the inspector, but if it's not there switching your texture type to "advanced" should show everything.

    Do not use those indie post-processing effects for any type of non-trivial game. They are ridiculously inefficient.
     
    jipjax likes this.
  10. blubbr

    blubbr

    Joined:
    Jan 14, 2019
    Posts:
    1
    Thanks, I looked for a solution because my bullet sprite looked pixelated. My sprite didn't have "Generate Mip Maps" enabled and when i turned it on, it looked much cleaner with smooth edges. To turn it on, select your sprite asset > Advanced > check Generate Mip Maps.

    Thanks smd863 and hippocoder
     
    Gdakkutlu likes this.
unityunity