Search Unity

  1. Unity Asset Manager is now available in public beta. Try it out now and join the conversation here in the forums.
    Dismiss Notice
  2. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  3. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Feedback Sprite-Lit-Default and BlendOP.Max

Discussion in '2D Experimental Preview' started by Gungnira, Apr 26, 2020.

  1. Gungnira

    Gungnira

    Joined:
    Mar 2, 2019
    Posts:
    9
    2D Lights and the Sprite-lit-default-shader are pretty cool. However, i miss the option to set the BlendOP.Max attribute somewhere.

    When lights are overlapping, the light intensity in the overlapping area doubles, which results in too bright lighing. Having a BlendOP.Max attribute could solve that problem very easy.

    Unfortunately i didnt managed to get that work in the Sprite-lit-default-shader. This topic discribes the problem a bit better:
    https://forum.unity.com/threads/ple...of-overlapping-lights-with-lwrp-in-2d.827370/


    Any ideas or help appreciated.