Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

SpeedTree Leaves/Fronds are pitch black on one side!

Discussion in 'General Graphics' started by Jakeiiii, Feb 4, 2017.

  1. Jakeiiii

    Jakeiiii

    Joined:
    Jul 7, 2014
    Posts:
    258
    So I've been messing around with SpeedTrees for the day and have finally gotten the hang of it. Only problem is that any leaves or fronds that I use on the treas are lit properly from one side, but the other is completely black! Changing the shadow settings on the mesh doesn't make a difference, and while I'm mainly using the "Nature/Tree Creator Leaves" shader for my frond material, the "Fast" version of the shader doesn't work either. These are the only two shaders I can use and I have no idea what's causing these to turn black on the other side.



    The lighting in my scene is fine as you can tell on the surrounding terrain, so... what gives? Using Unity 5.5.0f3.
     
  2. Jakeiiii

    Jakeiiii

    Joined:
    Jul 7, 2014
    Posts:
    258
    Okay, solved!
    Simply go to the speed tree object, on the tree component (that shows the base, branches, leaves, etc. in that connected diagram) select the base part and then turn Ambient Occlusion OFF.

    Makes sense since it wasn't receiving the ambient lighting...
     
    munozpro likes this.
  3. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    1,839
    Hi @Jakeiiii

    Where is this ambient occlusion option? In Unity? Or Speed Tree Modeler?

    for me, speed tree doesn't show any AO in Unity for some reason and been battling to find out why...
     
  4. Jakeiiii

    Jakeiiii

    Joined:
    Jul 7, 2014
    Posts:
    258
    The AO settings are in Unity. When you select your tree, and in the Inspector go to the base Tree component (not branches/leaves, etc.) and there should be a few AO options.
    I can't remember what my exact settings were to get them to look good, but turning it OFF was NOT a good solution.

    Instead, have it ON, but make the colour grey (not black or white) and then set the sliders to be quite minimal and nothing too intense. That way you have a nicely shaded tree.

    And this ISN'T for SpeedTree. Just the general Unity tree creator.
     
  5. castor76

    castor76

    Joined:
    Dec 5, 2011
    Posts:
    1,839
    Oh, I thought it was for the speed tree, because you talked about it based on the speed tree on the original post. :p
     
    ROBYER1 likes this.
unityunity