Search Unity

Graphics Speed tree billboard scaling (FIXED)

Discussion in '5.4 Beta' started by deverolirc, Apr 28, 2016.

  1. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Having another problem with speed tree, it seems my billboards do not scale correctly corresponding to the the mesh version, eg. I have trees placed with different scales and rotations, however you can see when the mesh tree comes in it is the scale which is set it where the billboard seems to have just a 1,1,1 scale.. Is it meant to be this way? Also, using the LOD group, and moving the camera slider, the trees billboards render properly.

    Thanks!
     
    Last edited: Apr 28, 2016
  2. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    did more testing.. it only happens when there is more then 1 prefab tree, if it is a single tree in the scene, the billboard scales properly, if there is more then 1 tree, billboards only scale at 1,1,1
     
  3. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Here are a couple pictures explaining..

    Billboard scales to wrong size upload_2016-4-27_16-49-3.png
    proper size, however billboards scales do not match up with it.
    upload_2016-4-27_16-49-30.png
     
  4. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Is nobody experiencing this? Its completely game breaking, it does not take rotation or scale into account on the billboards either? Please does anybody know what is happening?
     
  5. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
  6. Fuzzy

    Fuzzy

    Joined:
    Feb 11, 2011
    Posts:
    266
    Might be the best thing to send in a bug report with repro project and post the case number.
     
  7. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Thanks for the reply, Alright I will send in one, was just hoping there was a temporary fix for it!
     
  8. KyleOlsen

    KyleOlsen

    Joined:
    Apr 3, 2012
    Posts:
    218
    We're getting this issue in b17 too. Did you end up submitting a report already? You should post the bug number here for any developer eyes that pass by.
     
  9. HolyFireGames

    HolyFireGames

    Joined:
    Apr 23, 2014
    Posts:
    116
    Any update on this issue?
     
  10. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Sorry guys, I forgot to watch this thread, I am getting super frustrated with this bug, yea I submitted the bug with an example project, I will dig up the bug number when I have a chance. I would love an official response on this..... I am happy to hear I am not the only one getting this.
     
  11. zeroyao

    zeroyao

    Unity Technologies

    Joined:
    Mar 28, 2013
    Posts:
    166
    Hey the bug is fixed for the next (or the next next :)) 5.4 beta. Sorry for the trouble.
     
    m4d likes this.
  12. HolyFireGames

    HolyFireGames

    Joined:
    Apr 23, 2014
    Posts:
    116
    Last edited: Jun 1, 2016
  13. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Thank you very much!
     
  14. HolyFireGames

    HolyFireGames

    Joined:
    Apr 23, 2014
    Posts:
    116
  15. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Just tried the latest beta, the scale of trees is still broken though :( hopefully will be fixed in the next version!
     
  16. zeroyao

    zeroyao

    Unity Technologies

    Joined:
    Mar 28, 2013
    Posts:
    166
  17. HolyFireGames

    HolyFireGames

    Joined:
    Apr 23, 2014
    Posts:
    116
    Thanks! It's the last major speed tree issue we're facing in our game.
     
  18. deverolirc

    deverolirc

    Joined:
    Jan 19, 2014
    Posts:
    475
    Just updated to b21, and I can confirm this is fixed for me. Thank you guys very much for all your help!
     
unityunity