Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

[SOLVED] Visual Studio Community 2015: How to disable horizontal white bars under each code blocks

Discussion in 'External Tools' started by Raitoning, Feb 27, 2016.

  1. Raitoning

    Raitoning

    Joined:
    Dec 13, 2014
    Posts:
    100
    Hi everyone,

    Now that Unity is shipped with Visual Studio, I'm happy to reuse it ( I love MonoDevelop, but Visual Studio is for me maybe the best IDE ever made ). But in Visual Studio, white horizontal bars will show under each code blocks, i.e under using block, field declaration, under the class, etc... To be honest, those white bars are going to drive me crazy. I can't focus on developping when I got random bars showing up under some text. I've searched every where on internet without finding how to disable them. as a non English-native, I don't understand everything in the VS settings. If someone knows how to disable them, please tell me how ! I'm going to throw my screen trought the window because of those bars.

    bars.png

    Thanks for reading me, I hope some could help me :)

    Solution by MV10: Disable "Show procedure method separators" in Visual Studio options.
    I found this option in Tools Menu - Option... - Text Editor - ( Your dev language ) - Advanced - Show procedure line separators
     
    Last edited: Feb 27, 2016
  2. MV10

    MV10

    Joined:
    Nov 6, 2015
    Posts:
    1,889
    I agree with you, that would drive me crazy.

    I use VS2013 Pro, and Microsoft released an add-on which included those lines (see blog post here and check the comments at the end). They called these "method separators" so maybe that will help you find the setting.

    VS2013 doesn't have that by default for C#, but it does have it for VB here: Tools -> Options -> Text Editor -> Basic -> VB Specific. I'd check in the C# section of the Text Editor options for a setting if you haven't already.
     
  3. Raitoning

    Raitoning

    Joined:
    Dec 13, 2014
    Posts:
    100
    Wow, thank you ! You litteraly saved me lol.

    I can confirm that those lines comes from the method separators. Those are pretty annoying and useless in my opinon. they just cut the code into multiple parts and kind of prevent your eyes from seeing others parts of your code such as class fields and more...

    I found this option in Tools Menu - Option... - Text Editor - ( Your dev language ) - Advanced - Show procedure line separators

    Thanks again ! I'll put this solution in the first post and mark this thread as solved. Thanks for taking your time to save me and tons of other users ! :D