Search Unity

[Solved] Unity slow to open VS

Discussion in 'External Tools' started by Deleted User, Sep 10, 2015.

  1. Deleted User

    Deleted User

    Guest

    When I double click on a script inside Unity, it says "Opening Visual Studio. This may take a few seconds" but it actually takes a few minutes. I had to reinstall Windows recently and before I did that, Unity opened VS in literally just a few seconds so I don't know why it's so slow now.
     
  2. TonyLi

    TonyLi

    Joined:
    Apr 10, 2012
    Posts:
    9,703
    Google turns up a bunch of reasons for slow VS start times. Here are some things to check:
    • Clear your web caches and temp folders (e.g., AppData\Local\Temp). VS scans these at startup.
    • Fix any graphics driver issues. VS might be trying to initialize DirectX and timing out.
    • Fix network connectivity issues.
    • Check for any stale breakpoints.
    • If you're not using VS's integrated Git or TFS for version control, turn it off (Tools > Options > Source Control). Otherwise it'll scan the repositor(ies) at startup.
    If you figure out what's slowing down your VS, please post the solution here. Since Unity 5.2 has native VS integration, I'm sure lots of other people will run into the same situation, too.
     
  3. DarkPixel

    DarkPixel

    Joined:
    Sep 13, 2013
    Posts:
    79
    I have the same problem too, it's like 2-3 sec. with UnityVS / VS2013 but with 5.2 / VS2015 sometime it's more that 1min.
     
  4. Deleted User

    Deleted User

    Guest

    Tried that but didn't work. I'm still on 5.1.

    Same. I had VS2013 before and now I have VS2015 and unityVS2015.
     
  5. Matt1988

    Matt1988

    Joined:
    Sep 14, 2012
    Posts:
    23
    I'm having the same problem, sometimes it can take up to a minute for VS 2015 to open.
     
    arminelec likes this.
  6. ev3d

    ev3d

    Joined:
    Apr 19, 2013
    Posts:
    326
    i take it nobody found a solution to this?
     
  7. ev3d

    ev3d

    Joined:
    Apr 19, 2013
    Posts:
    326
    bump
     
  8. HolyShovel

    HolyShovel

    Joined:
    Jun 19, 2013
    Posts:
    156
    You can launch IDE before Unity. Launch Unity. Open C# project. Its will be start fast. Then you can close first opened IDE. But how solve general problem I don't now...
     
  9. miggymax

    miggymax

    Joined:
    Feb 18, 2017
    Posts:
    2
    me too same problem :(
     
  10. miggymax

    miggymax

    Joined:
    Feb 18, 2017
    Posts:
    2
    In meantime i went to Edit > Preferences > External Tools, and choose MonoDevelop

    Hopefully Unity will fix this as I have no clue what was happening.
     
  11. Deleted User

    Deleted User

    Guest

    Lol that's not a fix. I'd rather way a couple minutes then working with MonoDevelop. Anyway, the problem seems to have cleared up for me. Or at least I don't notice it too much.
     
  12. MattDiamond

    MattDiamond

    Joined:
    Jul 4, 2017
    Posts:
    3
    Visual Studio 2015 community edition i think with unity 2017.2 is blazing slow!!!!
    It takes about 3-4 and even 5 minutes in the baddest case to load a simple project.....

    My specs are:

    Intel Core i5 4288U 2.60GhZ and with TurboBoost enabled
    4.00 GB of DDR3 Ram (i should upgrade to the max 8GB) 1600MhZ
    500 GB HDD(really slow 5400 rpm, yes, i should upgrade to an 1 TB SSD)
    and A Nvidia Geforce GT920MX(DDR3, not amazing but good ;) )

    So it has some pretty decent specs... why it is taking SO MUCH to load??????????
     
  13. Flipbookee

    Flipbookee

    Joined:
    Jun 2, 2012
    Posts:
    2,383
    Any third party plugins installed in it? Resharper for example can make it blazing slow. Or you could try the new VS 2017, that’s much faster.
     
  14. DarkxxCrow

    DarkxxCrow

    Joined:
    Nov 16, 2013
    Posts:
    5
    <Off-topic>
    Your specs are barely decent for developing... unless you develop mobile games that is (Better get a desktop pc).
    </Off-topic>

    Anyway, somehow this was tagged as Solved, whereas I didn't find any fix for the problem. I personally think the hard drive speed is the one to blame at loading things.
     
  15. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    25,623
    Going from 2017.1 to 2017.3 does take longer to compile now than before. I guess that's related to the assembly stuff?
     
  16. contramonk

    contramonk

    Joined:
    May 26, 2018
    Posts:
    1
    I had the same problem and noticed that the external script editor was set to VisualStudio 2010 in edit > preferences > external tools. After switching this to VS 2017 everything is groovy.
     
  17. Kevin-Skyburn-Games

    Kevin-Skyburn-Games

    Joined:
    Dec 11, 2015
    Posts:
    4
    I had the same problem. I fixed it like Flipbookee mentioned by unistalling Resharper. I used Resharper for a while to try it out and after my trial periode was over I never removed (or subscribed) for it. After unistalling resharper everything works fine again!

    To unistall Resharper I first had to download the resharper installer again and then select uninstall.
     
    Flipbookee likes this.