Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

[SOLVED] Unity 5.1 Crash in Playmode

Discussion in 'AR/VR (XR) Discussion' started by S_P_S, Jun 9, 2015.

  1. S_P_S

    S_P_S

    Joined:
    Feb 25, 2015
    Posts:
    91
    Hello,

    just downloaded the the new Unity 5.1 release.

    I opened my project (previously created with Unity 5.1 (Beta)) in Unity and by hitting Play, the Editor crahshes. Both the 32-bit and 64-bit Version crashes. I am using Windows 7.

    Help would be nice.

    Regards
     
  2. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    29,159
    Do you have any meshes without materials assigned? Regardless, post a bug report please.
     
  3. Bennett-Lynch

    Bennett-Lynch

    Joined:
    Oct 11, 2014
    Posts:
    35
    Same problem here. Error-free project in previous version is freezing the editor every time I try to play in 5.1. Will submit a bug report but I'd caution anyone considering upgrading to wait to see how widespread this problem is.
     
  4. greg-harding

    greg-harding

    Joined:
    Apr 11, 2013
    Posts:
    489
    Error-free project from 5.0.2f1 also not working in 5.1.0f3 - missing behaviours and currently appears to have some missing defines in the script projects as well so they're not compiling correctly. Trying to track it down now...

    Edit: Missing defines was Xamarin/MonoDevelop switching to Release mode where no constants are defined. Switching back to debug fixes that. However, the initial re-import that 5.1.0f3 performs on the older project still breaks a few behaviours (they go missing).
     
    Last edited: Jun 9, 2015
  5. S_P_S

    S_P_S

    Joined:
    Feb 25, 2015
    Posts:
    91
    This problem even occurs if I build a new project with the new 5.1. But I also found out that it mostly only occurs if "Virtual Reality Supported" in PlayerSettings is checked. And I think it also occurs if "Virtual Reality Supported" is unchecked but you have "VRSettings..." Code that run.

    Regards
     
    tessa101 likes this.
  6. Aurore

    Aurore

    Head of Learn Content Production Unity Technologies

    Joined:
    Aug 1, 2012
    Posts:
    3,103
    When you have done a little more digging and sent over a bug report, please post the bug number here.
     
  7. S_P_S

    S_P_S

    Joined:
    Feb 25, 2015
    Posts:
    91
    Case 702920

    Regards
     
    Aurore likes this.
  8. Aurore

    Aurore

    Head of Learn Content Production Unity Technologies

    Joined:
    Aug 1, 2012
    Posts:
    3,103
    Can you try to remove any previous Oculus plugins and assets from your project, or update to the latest version that supports 5.1 as advised in the release notes.
     
  9. Bennett-Lynch

    Bennett-Lynch

    Joined:
    Oct 11, 2014
    Posts:
    35
    Mine randomly started working after having to force close it a few times. Really didn't change anything so not sure what more information I can provide. I'm now having a problem with some sprites I use for buttons randomly disappearing (that was not present in the previous version). Case 702918 but my project folder was far too large to submit.
     
  10. Aurore

    Aurore

    Head of Learn Content Production Unity Technologies

    Joined:
    Aug 1, 2012
    Posts:
    3,103
    Please try to keep different issues separate as this is a thread for a VR issue, please make another thread in the appropriate forum.
     
  11. S_P_S

    S_P_S

    Joined:
    Feb 25, 2015
    Posts:
    91
    As I said I build a complete new project so there are no Oculus plugins (not even any asset) and in the other project I removed every oculus Script, Plugin and Prefab.

    What I did:
    created a new project > imported nothing >went to Project Settings > Player > checked "Virtual Reality Supported" > hit play > Unity crashes

    Dont know what to do.

    EDIT: The issue is the same, whether I have a Rift connected or I have not.

    Regards
     
  12. LennartJohansen

    LennartJohansen

    Joined:
    Dec 1, 2014
    Posts:
    2,393
    Do you have the 0.6 Oculus runtime?
     
  13. S_P_S

    S_P_S

    Joined:
    Feb 25, 2015
    Posts:
    91
    I think my problem is solved. The Oculus runtime was the problem. I forgot that I downgraded the Runtime a few days ago, because with the Unity 5.1 Beta you should use the older Runtime.
    Now I have the 0.6 Runtime installed and it seems to be working.

    Special thanks to you, LennartJohansen! Also thank you Aurore that you took care!

    Regards
     
    Last edited: Jun 9, 2015
    Aurore likes this.
  14. gangafinti

    gangafinti

    Joined:
    Jun 13, 2013
    Posts:
    19
    Hi guys, so I have a oculus DK1 and unity 5.1 and I installed the lates oculus runtime SDK. The problem is that one I start up my build it crashes one 100% of the time. First it wouldn't detect a HDM but this page fixed thathttp://thenappingkat.azurewebsites.net/oculus-headset-unity-error-no-hmd-detected/ so now I put it on extende and run the oculus on the second screen which is my main screen. Does anyone have any idea why my build crashes 100% of the time? I exported my simple unity project whith Virtual Reality Suport on in the player settings. I have a deadline today and if someone knows the awnser to my problem I would be so insanely happy! :)
     
  15. thep3000

    thep3000

    Unity Technologies

    Joined:
    Aug 9, 2013
    Posts:
    326
    0.6.0 runtime has known issues with DK1 which Oculus is working on fixing. In the meantime it is recommended to use the legacy Oculus Unity Integration package and keep the "Virtual Reality Supported" checkbox unchecked for DK1.
     
  16. boxatom

    boxatom

    Joined:
    Mar 17, 2014
    Posts:
    4
    Hi, I received a DK2 this week, I installed the 0.6.0 runtime. If I build a project it works with the Unityplugin from oculus on oculus website. But when in editor, with the VRSupported... unity crashes as soon as I hit play.... By the way its unity 5.1. What am I missing?
     
  17. EdBlais

    EdBlais

    Unity Technologies

    Joined:
    Nov 18, 2013
    Posts:
    287
    Make sure you are using gamma lighting and that no objects in the scene reference the legacy Pluging. Linear lighting will be fixed in the next 5.1 patch. Are there any errors in the log? Is Unity crashing or just exiting Play mode? If Unity is crashing, have you submitted a bug report?
     
  18. boxatom

    boxatom

    Joined:
    Mar 17, 2014
    Posts:
    4
    Found out the problem.... on the unity's documentation for VR, read something about demo scene should work on oculus config.... I got confused because some apps did work and some did't, I had to set it as Extend Desktop to the HMD for it to work.... Then I launched Shoot Hero that was designed for mobile and desktop, and it worked automatically in the oculus... there are some stuff that needs to get fixed but could play it instantly... and it was nice, now can see the game from a new perspective.
     
  19. VegetarianZombie

    VegetarianZombie

    Joined:
    Jul 16, 2013
    Posts:
    14
    Just an FYI ... I'm running into this problem. If I check Enable VR Support, and then run the game, the editor will crash to the desktop. I'm guessing this is because I've unhooked my headset from my computer. It's not a big deal because these are just sample projects and I'm sure if I plug in my headset, the problem will resolve itself.

    Just for the sake of info, do you need to have your headset plugged in when VR Support is enabled?

    Thanks
     
  20. RedSaturnSix

    RedSaturnSix

    Joined:
    Apr 1, 2015
    Posts:
    1
    I'm having this issue now too. My DK 2 is plugged in.
     
  21. gamegirl1984

    gamegirl1984

    Joined:
    Nov 6, 2014
    Posts:
    102
    Anyone fix this? I just downloaded unity 5 and I have the box checked for VR but after I exit Play unity crashes. I have the new runtime...
     
  22. thep3000

    thep3000

    Unity Technologies

    Joined:
    Aug 9, 2013
    Posts:
    326
  23. 2cuppaDay

    2cuppaDay

    Joined:
    Aug 19, 2014
    Posts:
    1
    Thanks @thep3000, disabled Anti Aliasing in Quality Settings solve Unity crash when exit play mode with VR support enabled. Using DK2, runtime 0.7.0.
     
  24. jayseaCODE

    jayseaCODE

    Joined:
    Mar 31, 2015
    Posts:
    5
    Thanks @thep3000 that worked! I am using DK2, Unity 5.1.3f1, Oculus Runtime 0.6.0.1
     
  25. dovoto_

    dovoto_

    Joined:
    Mar 3, 2014
    Posts:
    1
    Had similar issues...

    Win 10, DK1 with newest SDK/utilities from Oculus (as of today) and newest unity (5.3.0f4 personnel).

    Scene was working fine yesterday, left unity on overnight, sat down and pressed play to remember where I was at and Unity crashed. If I deleted my Oculus camera rig it works.

    Unchecking the VR support in player settings seemed to have no affect on running it from within unity.

    This appears to be an Oculus runtime issue not a unity issue (just adding it here because there is a seemingly simple fix for others that might look here first). If you just restart the Oculus runtime service in windows it seems to fix the issue. At least, this fixes it for me.
     
  26. indrajith

    indrajith

    Joined:
    Mar 22, 2016
    Posts:
    1
    For some reasons, none of the above said methods fixed my issue. But my issue got solved by following the steps said here .
     
unityunity