Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Feedback [SOLVED] Unity 2019 - IL2CPP Google Mobile Ads Not Working

Discussion in 'Editor & General Support' started by PayandaOnline, May 22, 2019.

  1. PayandaOnline

    PayandaOnline

    Joined:
    May 5, 2018
    Posts:
    13
    Hello I'm Using GoogleMobileAds-v3.17.0 and Unity 2019.1.0f2.
    Ads don't work when I get il2cpp build with unity 2019.1.0f2. It works with mono when I get it build. what can we the problem is unity or google mobile ads?
    do to solve this problem?
     
  2. Peter77

    Peter77

    QA Jesus

    Joined:
    Jun 12, 2013
    Posts:
    6,625
    Please submit a bug-report as described in this document:
    https://unity3d.com/unity/qa/bug-reporting

    It's important that you report these issues together with a reproduction project if you want them to get fixed. If you don't do it, it might be a long time until someone else reports them or until Unity Technologies find them.

    After you submitted the bug-report, you receive a confirmation email with a bug-report Case number. Please post the Case number (number only, not the link) in this forum thread for Unity staff to pick up
     
    PayandaOnline and karl_jones like this.
  3. PayandaOnline

    PayandaOnline

    Joined:
    May 5, 2018
    Posts:
    13
    thank you. i'm submitted bug reports.
     
    Peter77 likes this.
  4. PayandaOnline

    PayandaOnline

    Joined:
    May 5, 2018
    Posts:
    13
  5. mayankela21

    mayankela21

    Joined:
    Jul 2, 2019
    Posts:
    9
  6. PhoebusP

    PhoebusP

    Joined:
    Nov 21, 2019
    Posts:
    1
    Hello! i face almost the same problem. My game worked fine (Mono stripping) till I decided to upload it to Google Play. There you need x64 and this is possible only with IL2CPP Stripping. Sadly. I edited the code above as @PayandaOnline said but nothing changed. My problem is exactly after the adv is over. The player can watch the adv but when you press the X (i mean the adv is over), the game doesnt crash, but not working properly. GameObjects appear and disappear with no reason. Any kind of help?
     
  7. PayandaOnline

    PayandaOnline

    Joined:
    May 5, 2018
    Posts:
    13
    maybe selected Managed Stripping Level = High is not working... please change Managed Stripping Level to Low and test again.
     
    PhoebusP likes this.