Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

[Solved] [ProGrids] Grid overlay not visible on objects (Mac OS X, Unity 2018.1.0f2)

Discussion in 'World Building' started by pippinbarr, Jun 3, 2018.

  1. pippinbarr

    pippinbarr

    Joined:
    May 24, 2016
    Posts:
    6
    Very new to ProGrids and can imagine this being a setting issue, but nonetheless I haven't been able to find any instructions/tips to that effect. The problem:

    - I add ProGrids to my project via the Package Manager
    - The grid (Y) is visible in green in the Scene View
    - I add a plane to the scene
    - The grid (Y) is not visible on the plane, but is visible around it

    That is, it "feels" like the grid is underneath the object and occluded by it. Snapping etc. works as expected.

    To complicate matters. If I install ProGrids via the Asset Store (deprecated I assume), I can see the grid (Y) in isometric top view over the top of my plane, but from no other perspective.

    Is this a setting? A Mac OS X problem? An idiocy of mine?
     
  2. kaarrrllll

    kaarrrllll

    Unity Technologies

    Joined:
    Aug 24, 2017
    Posts:
    445
    Hi Pippinbarr. No, this is a regression introduced in the Package Manager version of ProGrids. It has been fixed and an update is coming soon.
     
  3. pippinbarr

    pippinbarr

    Joined:
    May 24, 2016
    Posts:
    6
    Ah! Okay, that's just fine then. Thanks for clarifying!
     
unityunity