Search Unity

  1. Tune in to get all the latest Unity news live from Berlin on June 19, 6pm CEST. Set up a YouTube reminder!
    Dismiss Notice
  2. Unity 2018.1 has arrived! Read about it here
    Dismiss Notice
  3. Scriptable Render Pipeline improvements, Texture Mipmap Streaming, and more! Check out what we have in store for you in the 2018.2 Beta.
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Learn more.
    Dismiss Notice
  5. ARCore is out of developer preview! Read about it here.
    Dismiss Notice
  6. Magic Leap’s Lumin SDK Technical Preview for Unity lets you get started creating content for Magic Leap One™. Find more information on our blog!
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

[Solved] Issues with collaborate in 2018.1 (No Such Local File)

Discussion in 'Unity Collaborate' started by LegoDude, May 3, 2018.

  1. LegoDude

    LegoDude

    Joined:
    Nov 14, 2015
    Posts:
    10
    Hello all,
    A friend and I have been working on a project for the last month or so, using unity's collaborate feature. However, as of yesterday, we both updated to 2018.1 and Collaborate no longer works, when trying to download the changes my friend makes, i just get the error saying "No Such Local File" here's a quick clip
    https://gyazo.com/1cd5320be47ae187f6db5cfc6c5015be
    The console also gives me this error

    [Collab] FindChangedFile failed:
    Cannot find changed file UnityPackageManager/manifest.json -> Packages/manifest.json

    any help would be appreciated, Thanks!

    Edit: Fixed it, for anyone else with the issue, Simply delete your project folder, then let unity redownload your project from the cloud, will automatically set it up correctly.
     
    Last edited: May 3, 2018
  2. ledlamp

    ledlamp

    Joined:
    Apr 19, 2017
    Posts:
    4
    I had the same issue and resolved it by moving UnityPackageManager/manifest.json to Packages/manifest.json and trying again.
     
  3. ezonecom

    ezonecom

    Joined:
    Jul 23, 2013
    Posts:
    15
    Same thing happened here. I disabled Collaborate in the Services menu, quit Unity and then deleted the 'Library > Collab' directory in the project folder. Restarted Unity, re-enabled Collaborate, and everything worked.