Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice
Unity's version control component has been upgraded to Plastic SCM.

[Solved] How Do I Turn OFF Collaborate in Unity

Discussion in 'Unity Collaborate' started by Ayanami_Rei, Feb 28, 2017.

  1. Ayanami_Rei

    Ayanami_Rei

    Joined:
    Feb 28, 2017
    Posts:
    3
    I somehow wanted to try out this collaborate feature in Unity in one of my current project.
    However I find it taking up too much resources and performs slowly when the Internet Condition is unstable.
    Plus my team and I also use the Git for version control on the side, so I decided to turn this feature off in my project.
    But I couldn't find any button or option menu to toggle this off.
    Is there anyone who knows how to turn this off?
    Thanks!
     
    Etrimus and BurntIce96 like this.
  2. Ryan-Unity

    Ryan-Unity

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Hi @JoeyTribbiani! To turn off Collaborate, open the Services Window and click on the Collaborate option in the menu.
    Snip20170228_23.png

    From there, on the Collaborate service menu, click on the blue toggle button in the top right to turn off Collaborate.
    Snip20170228_24.png

    Thanks for giving Collaborate a try!
     
  3. Ayanami_Rei

    Ayanami_Rei

    Joined:
    Feb 28, 2017
    Posts:
    3
    Thank you, ryanc! I'll definitely try it again later.
     
    Ryan-Unity likes this.
  4. schmosef

    schmosef

    Joined:
    Mar 6, 2012
    Posts:
    852
    @ryanc-unity, Maybe you can help me with this issue:

    I bought an asset that's in the "complete projects/templates" category.

    The asset publisher used Unity Collaborate in his development.

    I don't use Unity Collaborate (yet). I host my own SVN server.

    After importing the asset into an empty project, I cannot set the Editor Settings>Meta Files to "visible". It's greyed out with a message saying "Version Control not available when using Collaboration feature."

    But since I'm not authorized on the Unity Collaborate project, when I open the Unity Services tab, I don't see any options for turning off Collaborate.

    So, since I cannot turn off Unity Collaborate, I cannot make the setting changes needed to add this project to my svn repo.

    I'm using Unity 5.6.0p3.

    Any suggestions?

    Unity Services Tab.png
     
    zoe_unity975 likes this.
  5. Ryan-Unity

    Ryan-Unity

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Hi @schmosef! I'll be happy to help however I can!

    No worries about not using Collaborate yet. Use whichever method works best for you.

    Could you tell me the name of the asset that you purchased from the Asset Store? I'd like to try to repro this issue on my machine too. We definitely don't want to keep users that download sample projects from the Store to not be able to modify their Editor Settings if they choose to not use Collaborate.

    For now, you should be able to unblock yourself by doing the following:
    1) Go into your ProjectSettings folder for your project.
    2) Open your EditorSettings.asset file and look for "m_ExternalVersionControlSupport:".
    3) Replace the string that's next to it with "Visible Meta Files" (since you said you wanted them to be visible) and Save.

    4) Open your ProjectSettings.asset file and look for "cloudServicesEnabled:".
    5) Underneath that option, double check that next to "Collab:" is 0 and not 1.

    Let me know if you're able to modify your Editor Settings inside of the Editor after doing the above.

    EDIT: Steps 2 and 3 aren't needed to let you edit your Editor Settings again.
     
    Last edited: May 2, 2017
  6. schmosef

    schmosef

    Joined:
    Mar 6, 2012
    Posts:
    852
    Hi @ryanc-unity,

    Thank you for the assistance.

    Here's the asset in question: link

    I'll try your workaround later tonight. Looks promising.
     
  7. schmosef

    schmosef

    Joined:
    Mar 6, 2012
    Posts:
    852
    Thanks @ryanc-unity!

    Just tested your workaround and it fixed my issue. I can now modify my Editor Settings.
     
    Ryan-Unity likes this.
  8. Alex_curiscope

    Alex_curiscope

    Joined:
    Apr 4, 2017
    Posts:
    55
    This has just happened to us (in 5.5.0f3), after importing an asset from an artist working in a separate project with Collab enabled into a project with Collab disabled. @ryanc-unity This seems like a bug to me (several bugs: the Collab setting is just a bool in the settings asset and could be changed by anything; some asset files seem to be locked in this scenario; users are unable to disable collab from the editor unless they have services access).
     
  9. Alex_curiscope

    Alex_curiscope

    Joined:
    Apr 4, 2017
    Posts:
    55
    Update: asset files being locked was not occurring / red herring.
     
  10. Ryan-Unity

    Ryan-Unity

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Hi @Alex_curiscope! Thank you for bringing this bug to our attention. We will be looking into this issue.

    Was the asset from the artist part of a .unitypackage? If Collab is unintentionally turned on after importing an asset, following the below steps will turn Collab Off until we get our fix in:
    1) Go into your ProjectSettings folder for your project.
    2) Open your ProjectSettings.asset file and look for "cloudServicesEnabled:".
    3) Underneath that option, double check that next to "Collab:" is 0 and not 1.
     
  11. Alex_curiscope

    Alex_curiscope

    Joined:
    Apr 4, 2017
    Posts:
    55
    Hey Ryan :) Thanks! The asset was from an artist. Their project is using collab, but our main project isn't.

    The confusing part of this was that some things were not being serialized in our project for some reason (we suspected that cache server was downloading stuff and overwriting our changes but we can't work out what was happening now). Anyway turning collab off in the settings asset fixed it, thanks again.
     
    Ryan-Unity likes this.
  12. mboylefls

    mboylefls

    Joined:
    Feb 28, 2014
    Posts:
    2
    I am having the same Issue...
    I am unable to open the project settings file..
    is there some sort of app to use for this?


    1. @ryanc-unity, Maybe you can help me with this issue:

      I bought an asset that's in the "complete projects/templates" category.

      The asset publisher used Unity Collaborate in his development.

      I don't use Unity Collaborate (yet). I host my own SVN server.

      After importing the asset into an empty project, I cannot set the Editor Settings>Meta Files to "visible". It's greyed out with a message saying "Version Control not available when using Collaboration feature."

      But since I'm not authorized on the Unity Collaborate project, when I open the Unity Services tab, I don't see any options for turning off Collaborate.

      So, since I cannot turn off Unity Collaborate, I cannot make the setting changes needed to add this project to my svn repo.

      I'm using Unity 5.6.0p3.

      Any suggestions?



    2. schmosef, May 2, 2017
    3. #4

    4. ryanc-unity

      Unity Technologies
      Joined:
      Mar 23, 2016
      Posts:
      341
      Hi @schmosef! I'll be happy to help however I can!

      No worries about not using Collaborate yet. Use whichever method works best for you.

      Could you tell me the name of the asset that you purchased from the Asset Store? I'd like to try to repro this issue on my machine too. We definitely don't want to keep users that download sample projects from the Store to not be able to modify their Editor Settings if they choose to not use Collaborate.

      For now, you should be able to unblock yourself by doing the following:
      1) Go into your ProjectSettings folder for your project.
      2) Open your EditorSettings.asset file and look for "m_ExternalVersionControlSupport:".
      3) Replace the string that's next to it with "Visible Meta Files" (since you said you wanted them to be visible) and Save.
      4) Open your ProjectSettings.asset file and look for "cloudServicesEnabled:".
      5) Underneath that option, double check that next to "Collab:" is 0 and not 1.

      Let me know if you're able to modify your Editor Settings inside of the Editor after doing the above.

      EDIT: Steps 2 and 3 aren't needed to let you edit your Editor Settings again.

      Last edited: May 2, 2017
      ryanc-unity, May 2, 2017
      #5

      schmosef likes this.
     
  13. schmosef

    schmosef

    Joined:
    Mar 6, 2012
    Posts:
    852
    notepad.exe :)
     
    Ryan-Unity likes this.
  14. iamsiannoob

    iamsiannoob

    Joined:
    Aug 4, 2017
    Posts:
    1
    When I change collab to 0, Unity says cannot disable Collaborate and checks for changes again.

    When I try to disable collaborate in the Unity Services tab, the slider briefly appears and dissapears. I managed to click it fast enough but it also says that I cannot disable Collaborate.
     
    GurinJaw and Dinac23 like this.
  15. schmosef

    schmosef

    Joined:
    Mar 6, 2012
    Posts:
    852
    I just had to use the technique again for a different Unity asset. Works fine.

    @iamsiannoob, I'm not sure what you mean by "checks for changes again". Are you trying to edit the ProjectSettings.asset file while the project is open in Unity?
     
    Ryan-Unity likes this.
  16. Unity3D_Tim

    Unity3D_Tim

    Joined:
    Jun 20, 2016
    Posts:
    2
  17. Trilunaire

    Trilunaire

    Joined:
    Dec 4, 2017
    Posts:
    2
    Hello,
    Every option didn't work for me, so I just removed all the line above cloudServicesEnabled (including this line) and it worked.
     
  18. bricksphd

    bricksphd

    Joined:
    Aug 29, 2017
    Posts:
    1
    Had the same problem, but changing Collab: from 1 to 0 did not resolve the issue. I finally got it to work by making the change, reopening the projecting, signing out of my account, closing the project, and reopening it. Then I could change my asset serialization mode again.
     
  19. justinpark001

    justinpark001

    Joined:
    Mar 6, 2015
    Posts:
    1
    This thread is a couple of years old but I'm still have the same problem and need a solution. Collaborate keeps turning itself on and I have to restart Unity to turn it off.
     

    Attached Files:

  20. Ryan-Unity

    Ryan-Unity

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Hi @justinpark001, could you please open a Support ticket so that we can better assist you:
    1. Navigate to project on the Developer Dashboard
    2. Select Collaborate > Support from the left hand menu
    3. Click on Open a Ticket and fill out the support form

    It would also help us to know which version of Unity 2020.1 and Collaborate you're using. If you could include those in your Support ticket then that will really help us in diagnosing the issue.
     
  21. schmosef

    schmosef

    Joined:
    Mar 6, 2012
    Posts:
    852
    @justinpark001, Sorry to hear that you are having issues with this.

    I can confirm that the solution provided by @ryanc-unity continues to work for me.
     
  22. cbrit

    cbrit

    Joined:
    May 8, 2020
    Posts:
    1
    In my case the Services page says Collab is off, and the ProjectSettings.asset file has "Collab: 0", yet Unity continues to show the "Version Control is not available with Collaborate enabled." message in my Project Settings window.

    I fixed it by enabling Collaborate and then disabling it again. Hopefully this helps someone. Seems like a bug.
     
  23. drakedane

    drakedane

    Joined:
    May 23, 2017
    Posts:
    62
    Lol. Would have been great, if you had included instruction on where to find the "Services Window". Clearly not open by default. Certainly, I have NOT been able to find it on my own. So unable to follow the rest of the instructions! I have only gotten errors, whenever I have bothered trying to check out this "collaborate" option. Finally decided to give up. But seems like it is constantly trying to do something, when I start Unity. Would prefer to just turn it off totally.
     
  24. drakedane

    drakedane

    Joined:
    May 23, 2017
    Posts:
    62
    Finally found tiny "cloud" icon that opened something called "Services". But says I don't have permission for that action! What does that mean? I recently upgraded from High Sierra to Catalina. But still using 2018 version of Unity. Maybe I should update? Always concerned about doing that, since it seems like I have encountered issues every time I have updated Unity or Visual Studio. Anyway, no way to turn this off, if Services doesn't load. So maybe it's already off. But, if so, not sure why the Collab button always seem to be "working", doing something. Can't help but think it might be using computer resources of some kind!
     
  25. Ryan-Unity

    Ryan-Unity

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Hi @drakedane, apologies for not being clear about how to bring up the Services Window. I'm glad you were able to find it. If you're using a version of Unity 2017.4+ then you can open the Package Manger to remove the Unity Collaborate package, which will completely uninstall all of Collab's components if you're worried that it's still running in the background.
     
  26. soyfeo123

    soyfeo123

    Joined:
    Jul 31, 2020
    Posts:
    12
    Hello, I am about to say something that is off topic but, when I was making a horror game in unity, unity made a black screen problem and after unity was closed, the black screen was gone and unity too.
    Why in the world did that make that happen? Some sort of bug? Glitch? Memory? Please tell me! I really want unity to make awsome games.
    Unity version: 2017.2.4p1
     
  27. Ryan-Unity

    Ryan-Unity

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Hi @soyfeo123, this is off topic for the Collaborate forum. Please post in the General Editor Support forum if you'd like someone that can help answer this particular question.
     
    schmosef likes this.
  28. newlife

    newlife

    Joined:
    Jan 20, 2010
    Posts:
    1,050
    How to disable collab in this case? There is no toggle

    upload_2020-9-15_19-20-53.png
     
  29. Ryan-Unity

    Ryan-Unity

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Hi @newlife, having the toggle button missing definitely doesn't help. Could you tell me which versions of Unity and Collaborate you're on?

    Could you try closing Unity, deleting the following folders, then reopening your Project to see if the toggle reappears:
    1. Delete your Packages folder:
      (Mac) <username>\Library\Unity\Packages
      (Windows) <username>\AppData\Roaming\Unity\Packages
    2. Delete the files in:
      (Mac) <username>\Library\Unity\Browser\Cache\Local Storage
      (Windows) AppData\LocalLow\Unity/Browser\Cache\Local Storage
     
  30. Artaani

    Artaani

    Joined:
    Aug 5, 2012
    Posts:
    423
    Have the same issue. There is no "on \ off" button.
    2020-10-01 19_44_52-Window.jpg
    Unity version 2019.4.9f1

    I tried to delete these files

    But it does not help.

    I suppose it is because this Unity user it is a "client" with limited control over project and no possibility to unlink project from the cloud. But that is very weird.
     
  31. newlife

    newlife

    Joined:
    Jan 20, 2010
    Posts:
    1,050
    Doesn't work either, using unity 2018. This is really weird. We cant even get rid of this unuseful collab in any way, so we are not using it and still we have to wait 5 mins every time while the stupid checking for changes thing.
     
    Marc-Saubion likes this.
  32. Marc-Saubion

    Marc-Saubion

    Joined:
    Jul 6, 2011
    Posts:
    652
    1) Go to window > Package Manager.

    2) Find "Unity Collaborate" and remove it.

    3) Don't forget to complain on the forum. They won't read it but you'll find fellow comrades who share your pain of dealing with the worst piece of software ever.
     
    el_Guero and schmosef like this.
  33. newlife

    newlife

    Joined:
    Jan 20, 2010
    Posts:
    1,050
    I already did, it doesnt work! The only way to get rid of this stupid checking for changes is to sign out from your account inside unity.
     
    Marc-Saubion likes this.
  34. Smileys

    Smileys

    Joined:
    Feb 27, 2014
    Posts:
    81
    Can confirm - nothing seems to remove this trainwreck of a software package.
     
  35. newlife

    newlife

    Joined:
    Jan 20, 2010
    Posts:
    1,050
    I contacted collab support and they replied:
    "I have checked your project and organization and I see that you have no assigned seats in Unity Teams. To be able to disable and enable Collaborate in the Editor, you need to have a seat in Teams".

    I added a seat in team and I was finally able to disable collab in Unity editor.
     
  36. Smileys

    Smileys

    Joined:
    Feb 27, 2014
    Posts:
    81
    Hey - thanks for your reply. I already have 2 seats in Teams. I have removed the collab package from my project but it still seems to work in the background (UI elements popping up when changing assets). I dont want to add that package again just to hit the "OFF" button.
     
  37. newlife

    newlife

    Joined:
    Jan 20, 2010
    Posts:
    1,050
    Not sure how you can fix this. You should contact collab support.
     
  38. Krzysztof_Poros

    Krzysztof_Poros

    Joined:
    Feb 13, 2020
    Posts:
    4
    This is ridicioulous. Checking for changes all the times, despite removing collaborate package. What a piece of S***...
     
  39. cordmeister

    cordmeister

    Joined:
    Apr 1, 2018
    Posts:
    6
    It appears support had abandoned this thread, but I’m here to report the same issue occurring in February of 2021. I have set up PlasticSCM with hopes of turning my disappointment with Collab into a distant memory only to suffer the “checking for changes” issue slowing my start-up to a crawl in spite of the Collab package being removed/disabled. Is there some sort of internal investigation within Unity to post-mortem the absolute embarrassment of Collab and its pervasive issues? How is it okay that critical issues and bugs from 2017 have not been addressed? Other than the shader keyword debacle, this is the most egregious flaw I’ve encountered within Unity, yet attempts to escalate the issue by the community are seemingly ignored. If every time you got in your car, it checked for fuel for 15 minutes before it allowed you to start the engine, there would be lawsuits galore. How are these issues allowed to perpetuate? And who from Unity is going to help me resolve the issue which now prevents me from using superior software from a company they’ve recently acquired—which adds to Unity’s obligation to me as a customer?
     
    Marc-Saubion likes this.
  40. newlife

    newlife

    Joined:
    Jan 20, 2010
    Posts:
    1,050
    Did you try to contact collab support? I did, and they helped me to solve this stupid issue.
     
  41. servobit

    servobit

    Joined:
    Apr 22, 2022
    Posts:
    4
    This problem appears in version 2022.1.4f1 as well.

    These steps from OP, worked for me:

    1) Go into your ProjectSettings folder for your project.
    2) Open your ProjectSettings.asset file and look for "cloudServicesEnabled:".
    3) Underneath that option, double check that next to "Collab:" is 0 and not 1.
    4) Restart Unity
     
    HCrowley likes this.
  42. krupps

    krupps

    Joined:
    Oct 17, 2017
    Posts:
    159
    You can also unlink and relink your project to get the annoying flashing to stop. Makes the IDE unusable in collaborate
     
  43. markhist2017

    markhist2017

    Joined:
    Feb 22, 2022
    Posts:
    3

    I don't get that window, I don't know what happens with unity, I click on Window/General/Services and I get the package manager window, I installed version 2023 and it looks the same, can someone help me solve this problem?, please Please, I can't deactivate the test mode for the ads and neither can the collaborate that activate it out of curiosity and now it produces compilation errors in my project, what can I do?
     
  44. markhist2017

    markhist2017

    Joined:
    Feb 22, 2022
    Posts:
    3

    Did you manage to open the services window? I couldn't, I need to deactivate the collab and the test mode of the ads
     
  45. markhist2017

    markhist2017

    Joined:
    Feb 22, 2022
    Posts:
    3

    Hello, I am using version 2022.1.0b9, I cannot find the services window and it bothers me to have the collab working without being able to deactivate it, I also need to deactivate the test mode of the ads, how can I solve this problem in this version?, greetings.. .