Search Unity

[Solved] Error: Arm64 executable included?

Discussion in 'iOS and tvOS' started by icebear007, Jun 25, 2019.

  1. icebear007

    icebear007

    Joined:
    Jun 8, 2016
    Posts:
    67
    [cross post from https://forum.unity.com/threads/error-arm64-executable-included.699872/]

    Hi,

    I recently started running into an issue with my built iOS bundle when I try to upload it via the Application Loader:

    Error ITMS-90700: "Incorrect Platform. You included arm64 executable 'xxx.app/xxx' in your iOS bundle. Only iOS executables can be included."

    I'm using the latest 2019.1 version (at time of writing this is 2019.1.7f1) with the latest compatible Xcode.

    Has anyone seen this before?

    Thanks,
    Alex
     
  2. icebear007

    icebear007

    Joined:
    Jun 8, 2016
    Posts:
    67
    Moving to new macOS and XCode versions fixed this issue for me. I'm now using macOS 10.14 and XCode 10.2.
     
unityunity