Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
Unity's version control component has been upgraded to Plastic SCM.

[Solved] Collaborate is making the editor run very slow

Discussion in 'Unity Collaborate' started by TheTortilla, Sep 23, 2020.

  1. TheTortilla

    TheTortilla

    Joined:
    Nov 25, 2013
    Posts:
    27
    Hello, I'm using Unity 2019.1.8f1

    Since this week collaborate makes the Unity Editor extremely slow (to the point that it's unusable).

    upload_2020-9-23_18-45-26.png

    Do someone have an idea of what could be causing it?

    (I live in Europe if it's relevant)

    It's not the first time that this issue occurred, but it solved it by itself after a few days/weeks the last time, I was guessing that it was related to Collaborate's servers.

    The editor runs smooth if I disconnect completely from the internet.

    I have run the Unity network reporter and it got stuck on messaging:


    C:\Users\<>\Downloads>unity_network_reporter.exe
    Inspecting interfaces...done
    Evaluating DNS resolution...done
    Evaluating TCP connectivity...done
    Evaluating HTTP connectivity...done
    Evaluating messaging...


    Thank you for your help!
     
    Last edited: Sep 23, 2020
  2. Ryan-Unity

    Ryan-Unity

    Unity Technologies

    Joined:
    Mar 23, 2016
    Posts:
    1,993
  3. TheTortilla

    TheTortilla

    Joined:
    Nov 25, 2013
    Posts:
    27
    Hello, thank you for your quick answer!

    Yes disabling Collaborate makes the editor fluent again, but I need Collaborate to work with my team and setting it on, off and on again tend to corrupt the project irremediably.

    None of the domains you sent seems to be reachable from my internet browser
     
    Last edited: Sep 23, 2020
  4. Ryan-Unity

    Ryan-Unity

    Unity Technologies

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    No problem. Are you using a VPN or firewall by chance? Have you checked to make sure that these domains are allowed through? If you've added them to an allow list and you're still having issues with Editor slowdown while Collab is enabled, then please open a Support ticket with us by doing the following:

    1. Navigate to project on the Developer Dashboard.
    2. Select Collaborate > Support from the left hand menu.
    3. Click on Open a Ticket and fill out the support form.

    I'll make sure that the Support Team responds as fast as they can.
     
  5. TheTortilla

    TheTortilla

    Joined:
    Nov 25, 2013
    Posts:
    27
    No we are not using a VPN and I tried disabling all the firewalls (windows, antivirus, router)

    The domain names unity.com and unity3d.com and pubnub.com (not the other ones) you mentioned seem to work when preceded by https:// (instead of http://unity.com/?_ga=2.72081683.1287398620.1600780696-1956719480.1593171706... when I click on your links, was I supposed to do something else?)

    I will send a support ticket, thanks!
     
    Last edited: Sep 23, 2020
  6. Ryan-Unity

    Ryan-Unity

    Unity Technologies

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Thank you for checking your firewalls. The domain names were mainly for in case your firewall was the culprit for your machine having trouble connecting to Collab. But from what you've said, that doesn't seem to be the case. Please be sure to submit your Network Reporter log and a link to this post (if you haven't already) when our Support Engineer responds to your ticket so that they can investigate it further. I'm sorry I don't have any other suggestions. We won't know for sure what else we can try until we get the details from your ticket.
     
  7. TheTortilla

    TheTortilla

    Joined:
    Nov 25, 2013
    Posts:
    27
    Okay, thank you for your help!

    I resolved my issue by contacting my Internet Provider, they were blocking HTTP connections and only allowing HTTPS
    Collaborate seems to need to communicate with http (without s) continuously and wait for an answer almost every frame.

    (how can I mark the topic as solved?)
     
  8. Ryan-Unity

    Ryan-Unity

    Unity Technologies

    Joined:
    Mar 23, 2016
    Posts:
    1,993
    Happy to help!

    Though I'm surprised that resolved your issue, since all of Collab's connections to its dependent services use HTTPS, so those should have been unblocked already. Did your ISP happen to mention which connections were using HTTP?

    (I took care of that for you.)
     
  9. TheTortilla

    TheTortilla

    Joined:
    Nov 25, 2013
    Posts:
    27
    They didn't mention anything else about it... Sorry.
     
  10. unity_i9inUgyF9FvWRA

    unity_i9inUgyF9FvWRA

    Joined:
    Jun 9, 2021
    Posts:
    1
    me and my team had the same issue but iam reaching the domains upove without any problem
    any help ??