Search Unity

[solved]bone animated blender model -> Strange Import Err

Discussion in 'External Tools' started by reculum, Jul 4, 2010.

  1. reculum

    reculum

    Joined:
    May 16, 2010
    Posts:
    60
    Hi there,

    after trying out this and that, i'm now learning to animate characters using bones.
    So i created my first model, a sign with bones,
    and imported it into unity.
    After instantiating, however, unity spammed the box with strange error messages which didn't stopped to occur until i removed the instance. (i didn't started the game yet).

    So, for all the 'fans' of my bee model, here is another 100% professional ... well ... sign.
    It doesn't contain animations yet, it just contains some bones which are all parenting the same single mesh... just look into it, and please tell me what i've done wrong.

    here are some of the strange errors:
    Code (csharp):
    1.  
    2. !node->m_AABB.IsValid()
    3. !ss->GetLocalAABB().IsValid()
    4. !IsFinite(outDistanceForSort)
    5. !IsFinite(outDistanceAlongView)
    6. !sh->m_AABB.IsValid()
    7.  
    from here on it keeps repeating ... unil you remove it, as mentioned.

    After a quick lookup for this error, i've found a lot of old posts where they had problems with particle emitters and particles themselves,
    but nowhere i found something about bone animated meshes.

    I tried it with another mesh before, and the error must have to do anything with this bones, since in its former version, there were no problems.

    Could anyone tell me what i've done wrong in blender ?
    (In blender itself, it doesn't cause any problems)

    Kind Regards,
    David
     

    Attached Files:

  2. reculum

    reculum

    Joined:
    May 16, 2010
    Posts:
    60
    hey i *really* need help here,
    since bone based animations are offering a lot of things to do with.

    here is what i'd done:
    1. Builded a model that looks like a "T" by extruding a cube several times.
    2. I added an armature
    3. I added some Bones which to the armature. (extruding)
    4. I resized some of the bones to make them catch the vertices that they should (turned on this visualization which shows the bones influence)
    5. I parented the object in edit mode to the armature

    Something that i'm missing? Anyone had several issues ?
    I didn't created animations so far, since i wanted to move the bones directly in my code.

    Really hoping for someone's help here.

    Kind Regards,
    David
     
  3. ShadyAlien

    ShadyAlien

    Joined:
    Aug 28, 2009
    Posts:
    208
    I had a problem similar to this with blender, I discovered that you can't use bone envelopes to rig your model. Unity only supports bone weights. I believe if you have "Vert. Group" and "envelopes" both on in the Armature modifier it won't work (at least that's what fixed it for me). Hope that helps.
     
  4. reculum

    reculum

    Joined:
    May 16, 2010
    Posts:
    60
    hi,

    at last, a reply.

    I thank you very much for your reply,
    but i fear it didn't helped, i get the same error over and over.
    It doesn't matter where i place the bones, how much of them ... nothing seems to matter, which is strange enough.

    May i ask what blender version you use ?
    i use 2.49b

    I noticed another odd thing: When i load my blender models, later on, it is no more possible to change the poses ... i can still move the bones, but they do no longer influence the mesh.

    I finally got to render my mesh in unity when i got into my bone object, and changed quality to "one bone".
    Then, it was strange that my "Cube" object was an invisible movable piece, while my bone object actually contained my rendered mesh.
    (When i played around with the unity examples, this little invisible gameobjects always where the bones ... moving them lead to deformation of the mesh)

    edit:
    i believe i misundestood you at first .. and deactivated envelops AND vertex groups ...
    in the other thread i got the hint, to only use vertex groups (didn't knew you meant that with "weights").
    Thus, i can say, both of you were absolutely right.
    Thanks for helping me out here :)

    regards,
    david