Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

[SOLVED] Ambient Occlusion Post Process displaying incorrectly with Forward Rendering

Discussion in 'Image Effects' started by HH_DanPowell, Apr 6, 2017.

  1. HH_DanPowell

    HH_DanPowell

    Joined:
    Jan 31, 2017
    Posts:
    5
    SOLUTION: Known issue with earlier engine versions. Upgrade to Unity 5.6.

    -------------------------------------------------------------------


    Hello, I am experiencing a problem with the Ambient Occlusion within the Post Processing Stack.

    I have attached a couple of screenshots to illustrate the issue.


    Ambient Occlusion with a Forward Camera appears correctly in the Scene Viewport:



    However, in the Game view, only the Ambient Occlusion pass is showing:



    • The Ambient Occlusion debugging mode is not active.
    • Ambient Occlusion displays correctly in the Game view when the Camera is set to the Deferred rendering path.
    • The issue persists even when the Ambient Occlusion Intensity is set to a crazy small value, such as 0.0001.
    • The issue seems to persist regardless of my Post Processing Stack settings.

    Here's a couple screenshots of the Quality and Graphics settings in the project, in case these are relevant.

    Graphic Settings: http://i.imgur.com/1RPTSL3.png
    Quality Settings: http://i.imgur.com/9IImJRP.png

    Any help/advice on the matter would be greatly appreciated.

    Cheers!
     
    Last edited: Apr 6, 2017
  2. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,726
    Perhaps disable force forward for deferred.
     
    HH_DanPowell likes this.
  3. HH_DanPowell

    HH_DanPowell

    Joined:
    Jan 31, 2017
    Posts:
    5
    Hiya hippocoder, thanks for the reply.

    Sadly disabling the "Force Forward Compatibility" option doesn't fix the issue.

    Even when I reset the Ambient Occlusion settings to their default values it still appears incorrectly when I'm using a Forward Camera.

     
  4. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,726
    Do you have any other cameras rendering or any such things? I would recommend filing a bug report with example scene, this will get looked into and fixed. I assume you are using the very latest post process version too? What Unity version (this always matters) and so on... not enough information to troubleshoot really :/
     
    HH_DanPowell likes this.
  5. HH_DanPowell

    HH_DanPowell

    Joined:
    Jan 31, 2017
    Posts:
    5
    • Unity 5.5.2
    • Latest version of the Post Processing Stack effects.
    • Only one Camera in the scene (Main Camera).


    I created a completely fresh project with no Packages except for the PostProcessing package. Dropped a couple cubes in the scene. Added the Post Processing Stack to my camera, and I get the same result.

    Looks correct in Scene view:



    Looks wrong in Game View:

     
  6. HH_DanPowell

    HH_DanPowell

    Joined:
    Jan 31, 2017
    Posts:
    5
  7. Chman

    Chman

    Unity Technologies

    Joined:
    Feb 6, 2010
    Posts:
    721
    You have Forward + MSAA enabled. It's a known issue with 5.5 and it's fixed in 5.6.
     
    HH_DanPowell likes this.
  8. HH_DanPowell

    HH_DanPowell

    Joined:
    Jan 31, 2017
    Posts:
    5
    Ah, that's great -- I've updated the project to 5.6 and it's working as expected.

    Cheers all!
     
  9. shumumazzu

    shumumazzu

    Joined:
    Jan 23, 2018
    Posts:
    1
    I disabled anti aliasing in the quality, in the project settings and that fixed it for me
     
    CiconiaStudio likes this.
unityunity