Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

[Solved] 2019.3.0a4 incompatible ndk

Discussion in 'Linux Editor' started by jooleanlogic, Jun 1, 2019.

  1. jooleanlogic

    jooleanlogic

    Joined:
    Mar 1, 2018
    Posts:
    332
    This version requires ndk19 yet hub still downloads ndk16.
    I can't even find the very specific ndk19 version it requires on google.

    - Update 15-Jun-19 -
    Solution found here
    Short of it is to use ndk r19 and not r19b which is latest.
     
    Last edited: Jun 14, 2019
    b1oki likes this.
  2. b1oki

    b1oki

    Joined:
    Dec 21, 2018
    Posts:
    7
  3. jooleanlogic

    jooleanlogic

    Joined:
    Mar 1, 2018
    Posts:
    332
    Beniamino likes this.
  4. Beniamino

    Beniamino

    Joined:
    Jul 25, 2015
    Posts:
    17
    I agree completely. I have downloaded several and am just getting the same thing every time. It says we need NDK r19 (64-bit) (19.0.5232133). I have installed numerous versions of Unity as well as the SDKs, JDKs, and NDKs. This is wasting a whole lot of time, and nowhere can I find 19.0.5232133.
     
  5. Beniamino

    Beniamino

    Joined:
    Jul 25, 2015
    Posts:
    17
    I think I was able to get the AAP to work by using 2019.3.0b4 and using all three recommended tools, but it seems JDK is not installed.and the other two aren't using the recommended ones. Let me know if anyone still doesn't have it working.