Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  2. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

Sketchup Models Perform Poorly and bring Editor to a halt.

Discussion in 'Editor & General Support' started by jkoll66, Jul 10, 2019.

  1. jkoll66


    Jun 3, 2019
    I'm very new to Unity. I've been tasked to build a walk-through of a conveyor system. It is quite large. The problem is when I drag a .skp file into Unity and then into my scene Unity slows to a crawl. If I play the "Game" it shows batch counts in the 100,000s. If I explode the model beforehand it seems to actually run better in Unity. It doesn't make sense, because the .skp file becomes much larger after exploding. I've tried occlusion culling (baking takes forever) and generating lightmaps. Quality set to Medium. Shadows turned off. Doesn't seem to make much difference to the performance. Is Sketchup the problem?

    Thanks in advance!

    p.s. The model contains Dynamic Components from Sketchup if that makes a difference.

    Using a Dell Precision 7520 Laptop
    Unity 2019.1.8f1
    Windows 10
    Core i.7 - 3.1 GHz Processor
    32 GB Ram
    NVIDIA Quadro M2200