Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Unity 2022.2 is now available as the latest Tech release.
    Dismiss Notice
  3. We are making some changes to the DOTS forums.
    Dismiss Notice
  4. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Bug Sketchup Export general issues, illegal character

Discussion in 'Unity Reflect' started by DriesVrBase, May 10, 2022.

  1. DriesVrBase

    DriesVrBase

    Joined:
    Mar 24, 2020
    Posts:
    48
    Hi,

    We just started using Sketchup for exporting models. Previously we only used Revit.
    Now there are some issue with Sketchup we previously had with Revit as well.

    First of all:
    In Sketchup 2021, there is no indication when a model is exporting. It's just unresponsive until it becomes responsive and is done. For large models this is quite annoying because this can take a while.

    But this isn't the largest issue. In Sketchup there is an issue where the export eventually ends and completes, but in Unity completely fails and doesn't import the model because there is an object in the scene with an 'illegal' character. (meaning é,è,... I guess)
    This is a file we got from an external client so I can't share it but it's a large file so it's not easy to go through all objects. There is also no name mentioned what the illegal character is or on what object. We've had this issue in Revit as well in the first days of Reflect. This is really annoying since I only have 10 days left till we have to present the model and I can't even export it. Please fix this asap.

    Edit: I have tried other models from the same client, and those work fine.

    Edit 2: Managed to get the model imported. I deleted a lot of objects until I managed to get it imported in Unity. Eventually it imported and I got some new errors. Posting them below. It still gives the error but it imports the model in Unity so that's nice I guess. I'm still not sure what the illegal character is. based on the errors it looks like it's the '#' but there are a lot of objects that have the '#' in them in Sketchup.



    Edit 3:
    It wasn't the '#'. I found the object that causes the issue and I'll post the group below that causes it.
    There is no special character in the name and I can't seem to figure out what is causing the problems. maybe a hidden character somewhere?

    Final Edit:
    I Removed all the objects that were an object like the one mentioned above and I only let one component stay with the name '<Cafe_Assembly_8_Component_233>. It was the only one left in the scene. When I exported it. It failed again. I then changed the instance and definition to another thing like '123thisisaTest'. And then the export worked. So I'm pretty sure it has something to to with the name. Maybe it has something to do with "Assembly" in the name or "Component" and Unity can't handle that? I'll do a few more tests but I can't figure out what actually causes it

    Okay I did the last test and I copied the definition from sketchup in a my google search bar.
    There is a hidden character between 'assembly' and '3'. I don't know how it got there. I'll get back to the client to ask if he knows it, but I doubt it. It looks like a small 'us'. I'll post a picture below. If I go through the name in the definition, I have to press twice on the arrow key to go from the end of 'assembly' to '3'. It's a hidden character.
    Maybe some kind of safety should be built in in the importer so it can handle these kind of issues?
    Picture below are pictures of my url bar and google search bar.

    I hope someone from Unity can do something with this?


     
    Last edited: May 10, 2022
  2. Unity_Derek

    Unity_Derek

    Unity Technologies

    Joined:
    Aug 24, 2021
    Posts:
    48
    Hello,

    Is there any chance you can provide the log file of the editor? If you follow this url, it tells you where you can find it. If you are on Windows, it is:

    %LOCALAPPDATA%\Unity\Editor\Editor.log
     
  3. DriesVrBase

    DriesVrBase

    Joined:
    Mar 24, 2020
    Posts:
    48
    Here it is. It's quite a big log because I did many attempts. But if you search for 'illegal' you can find some places where it happened.
     

    Attached Files: