Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Simple animation worked yesterday, doesn't today, despite doing the same thing?

Discussion in 'Getting Started' started by MxTellington, Oct 9, 2021.

  1. MxTellington

    MxTellington

    Joined:
    Oct 9, 2021
    Posts:
    1
    Hi! I'm very new to Unity and trying to make my first game. Yesterday I managed to make a character and animate it (I followed this tutorial, the animation part is around 30' I think). I exited without saving, as it was only a practice run and I figured I could do it again. But today when I came back to Unity it just... didn't work, despite doing what I remember to be the same thing as yesterday.

    What I'm doing:

    1. Creating a sprite with the first image of my animation

    2. Importing all the frames of my animation

    3. Dragging and dropping them all at the same time in the hierarchy zone

    4. Giving a name to my animation and saving it

    5. Now instead of creating a little animated character like it did yesterday, it creates another static character, with the same name as my sprite from step 1
    When I try to view my animation in the preview area it tells me "No model is available for preview. Please drag a model in the preview area".

    Do you know what I did wrong? I don't see the difference with what I did yesterday that worked, and I'm following these steps very closely, to no avail.

    Thanks.