Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Graphics Shuriken Particle System emitters behave differently in play mode to scene view

Discussion in '5.4 Beta' started by JamesSen_DS, Mar 16, 2016.

  1. JamesSen_DS

    JamesSen_DS

    Joined:
    Jan 13, 2016
    Posts:
    12
    I've just upgraded from 5.3.3p3 to 5.4b10 to resolve the issue with PhysX physics.processing spikes causing huge frame drops in our simulators. In the process of upgrading I've notice some of our particle systems using cone shaped emitters no longer function correctly in play mode and are now producing multiple streams of particles from the emitter instead of emitting in the preset cone shape.

    The emitter looks correct in scene view:
    upload_2016-3-16_13-32-4.png

    but when switching into playmode i'm seeing the following:
    upload_2016-3-16_13-33-55.png

    and here's the settings:
    upload_2016-3-16_13-37-26.png

    Am I missing something which needs re-configuring with 5.4?

    J
     

    Attached Files:

  2. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,299
    Hi,

    I don't think we are already aware of that issue.
    If you could log a bug with a small repro project I will look at it promptly!

    There shouldn't be anything special you need to do after upgrading, this sounds like a bug on our side.

    Thanks,
    Richard
     
  3. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,299
    Also, one thing to check: Does unticking Enable Interior Collisions fix it?
     
  4. JamesSen_DS

    JamesSen_DS

    Joined:
    Jan 13, 2016
    Posts:
    12
    Unticking Enable Interior Collisions does not fix it however, In an attempt to produce a repro project it seems to work correctly.

    I went back to my original project and turned off the attached scripts and changed the particle system to play on awake and it is now working correctly. So the issue seems to be in 1 of our scripts after upgrading.

    I'll update with further info once I've found the problem
     
  5. JamesSen_DS

    JamesSen_DS

    Joined:
    Jan 13, 2016
    Posts:
    12
    Solved:

    Emitter.Play() was being called by our script every Update(), it seems it now restarts the particle system from the beginning with each new call to Play() whereas it didn't before.