Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Question "Show Wireframe" doesn't show wireframe but transparent mesh/whole faces

Discussion in 'Editor & General Support' started by angiemon, Aug 12, 2022.

  1. angiemon

    angiemon

    Joined:
    Mar 26, 2018
    Posts:
    20
    Hi!
    So I don't know if this is a bug, I'm stupid, unknowingly triggered some setting or all of the above, but suddenly the preview of wireframes is very weird.

    In the Scene window, when switching the shading mode to wireframe at the right upper corner (or left if you use 2020 or prior versions), I get this:


    (doesn't matter if previewed in the scene, scene greyed out or isolated as seen in the picture)
    "Shaded Wireframe" basically looks exactly like "Shaded".

    When opening "Show Lightmap" (you know, in the mesh inspector where the respective lightmap UVS are then highlighted) I'm greeted with a similar problem:


    so no chance of seeing anything unless you hide the "wireframe" altogether in the right upper corner.

    I'm using Unity 2021.3.8f1 (LTS that was just released) and the HDRP.

    It happens in all the other scenes in this project as well. What gives? It's not a total gamestopper, but definitely a PITA and slows me down. I couldn't find anything online, maybe I was using the wrong search terms.

    Anyone know anything?
    Thanks!!