Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Show All Colliders in Editor? SOLVED

Discussion in 'iOS and tvOS' started by afrim, Sep 14, 2010.

  1. afrim

    afrim

    Joined:
    Oct 8, 2009
    Posts:
    4
    Is there a way to show all colliders in the editor at once? Instead of having to select each collider to see its bounds in the view port.

    I am making a 2D game and have everything drawn in a single texture on a plane. I then have empty game objects with box colliders on them for the areas that require collision detection. However I cant find a way to see all of them at once.

    I kinda figured out the answer as I was typing this question. I then went ahead and tested it and sure enough it worked! Not the ideal solution as I still cannot see all collision meshes while adjusting individual ones. Makes it hard to align things properly

    ANSWER:
    Create an empty game object as a parent. Add empty game objects with collider as children.
    Selecting the parent object will render the collision meshes for all sub objects in the editor.
     
  2. Ntero

    Ntero

    Joined:
    Apr 29, 2010
    Posts:
    1,436
    Also, you can Shift click and select all of the individual GameObjects on the Hierarchy.
     
    sederfan likes this.
  3. AmazingInt

    AmazingInt

    Joined:
    Dec 7, 2009
    Posts:
    157
    AnjaliGopar15 likes this.
  4. AdamZbadam

    AdamZbadam

    Joined:
    Sep 17, 2014
    Posts:
    1
  5. Bananozuar

    Bananozuar

    Joined:
    Oct 15, 2016
    Posts:
    6
    Just type >t:Collider< (without > <) in hierarchy's search box, this will highlight every object with collider in the scene. Then you can easily select them all.
     
    bhoffman67, lweks, piratemyke and 7 others like this.
  6. Wilbert-Blom

    Wilbert-Blom

    Joined:
    Aug 13, 2011
    Posts:
    109
    Deleted User likes this.
  7. 26PM

    26PM

    Joined:
    May 2, 2014
    Posts:
    7
    Thank you! t:meshCollider and t:boxCollider also work to further refine your search if needed.
     
  8. syllabusgames

    syllabusgames

    Joined:
    Oct 21, 2017
    Posts:
    1
    Since AdamZbadam’s link is broken, the check box to make all colliders visible is under Edit > Project Settings > Physics 2D > Gizmos > Always Show Colliders.
     
  9. Ultroman

    Ultroman

    Joined:
    Mar 10, 2014
    Posts:
    110
    Since this has already been necroed, and this is one of the first results on Google when searching for showing unselected colliders, I will share a simple, litte gem for primitive 3D colliders.

    I wrote a script/component which can show all capsule, box and sphere colliders present on a gameobject, with an option to include colliders on its children. Very useful when playing around with bones for e.g. a ragdoll and such.

    https://ultromanthetacoman.wordpress.com/2018/02/23/draw-unselected-colliders-in-unity/
     
  10. lexi89puzzle

    lexi89puzzle

    Joined:
    Feb 22, 2017
    Posts:
    10
    Thank you for this, for anyone else, use this answer. this is the most straightforward way of doing this, without writing any script
     
    YawJatah likes this.
  11. roointan

    roointan

    Joined:
    Jan 8, 2018
    Posts:
    78
    Skunk-Software likes this.
  12. zeropointblack

    zeropointblack

    Joined:
    Jun 8, 2020
    Posts:
    197
    lmao. nope. doesnt work either. looks like this is another lost cause.

    we literally have 3d objects in our scene that we are working on and trying to edit, which we cannot see. how amazing is that.

    tried about everything in this thread.

    anyone have any more time wasting ideas to try? surely there must be a way to see what youre working on without writing your own script or selecting everything in your scene, right?
     
    Last edited: Apr 3, 2021
  13. nandanramesh13

    nandanramesh13

    Joined:
    Sep 27, 2020
    Posts:
    4
    Just enable in project preferences and then make sure you enabled the colliders in gizmos in scene view
     
  14. Mirvini

    Mirvini

    Joined:
    Jul 25, 2013
    Posts:
    11
    Enable what in project preferences?
     
  15. Rachan

    Rachan

    Joined:
    Dec 3, 2012
    Posts:
    739
    Thank you very much!!!
     
    ohyesplease likes this.
  16. PandemoniumLord

    PandemoniumLord

    Joined:
    Feb 18, 2021
    Posts:
    1
    So I just was having this issue, and the solution I found made me feel really stupid. I had simply accidentally toggled off the gizmos. Hope this helps anyone still struggling with this.
    upload_2022-5-13_13-26-10.png upload_2022-5-13_13-26-47.png
     

    Attached Files:

  17. ohyesplease

    ohyesplease

    Joined:
    Feb 19, 2018
    Posts:
    13
    the check box to make all colliders visible is under Edit > Project Settings > Physics 2D > Gizmos > Always Show Colliders.