Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Question Shadows not showing with URP and Oculus Quest 2

Discussion in 'VR' started by danielesuppo, Sep 7, 2022.

  1. danielesuppo

    danielesuppo

    Joined:
    Oct 20, 2015
    Posts:
    317
    Hello, I've started a project for Oculus Quest with URP.
    Actually I have a very simple scene: a plane, a cube and a direct light with hard shadows
    In Editor there's the nice shadow of the box onto the plane, but when I build for Quest the shadow is not there.
    I've checked every possible setting, and I'm using the "URP-HighFidelity" pipeline asset.
    (P.S. I never had such a problem with Legacy Render and Quest2)
    I've searched on Google for a solution, but I could not find anything.
    It's the 1st time I use URP, maybe I'm missing something very obvious?
    Any help would be much appreciated
    Many thanks
     
  2. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    2,530
    Is the high fedelity asset also default for android? To rule this out delete all other quality presets.
    Also, what Unity version?
     
  3. danielesuppo

    danielesuppo

    Joined:
    Oct 20, 2015
    Posts:
    317
    Yes, the high fidelity is set for Android too (both PC and Android have the same quality level).
    I'm using Unity 2022.1.13f1
    Furthermore, If I use a spotlight in place of the direct light, the light does not show at all.

    *** ALMOST FOUND A SOLUTION ***
    It's weird: I've created a new project with the URP Sample scene, in which I've created the very same scene, with the same settings for the light, for the pipeline, and for every most common setting (that I know), and in this new project the shadows work (and for the spotlight too)!!

    I'm really confused, I think that there are 2 possible answers:
    1 - I'm really missing some specific option/parameter somewhere
    2 - There's a huge bug in last Unity versions.

    I think (and I hope) that it's my fault, but I don't know anymore what to check, after:
    - light settings
    - player settings
    - quality settings
    - pipeline settings
    - pipeline render settings
    - XR - oculus settings

    P.S. Unity is wonderful, it seem like a lottery: sometimes you can do that, sometimes you can't...
     
    Last edited: Sep 7, 2022
  4. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    2,530
    Probably missing some settings. Maybe check graphics settings and the URP asset and compare them?
    And the camera and light settings in the scene?
     
  5. danielesuppo

    danielesuppo

    Joined:
    Oct 20, 2015
    Posts:
    317
    *** SOLVED ***
    I had to enable "Reflection Probes" --> "Box Projection" in the URP Pipeline.
    I didn't have idea that this option could enable/disable shadows and lights in general (spotlights / pointlights), just on Oculus... :confused:
     
  6. Liminal-Ridges

    Liminal-Ridges

    Joined:
    Oct 21, 2015
    Posts:
    238
    doesnt work for me
     
  7. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    2,530
    Make a new post with all the detail
     
    Liminal-Ridges likes this.