Search Unity

  1. Unity Asset Manager is now available in public beta. Try it out now and join the conversation here in the forums.
    Dismiss Notice
  2. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  3. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Shadow resolution is ignored?

Discussion in '2D Experimental Preview' started by bobbaluba, Jan 7, 2021.

  1. bobbaluba

    bobbaluba

    Joined:
    Feb 27, 2013
    Posts:
    81
    With hard shadow, the borders look quite jagged compared to the other content in my game.

    Example:

    upload_2021-1-7_9-51-26.png

    Now in the Universal Render Pipeline Asset, there is a "Shadow Resolution" parameter, but looks like it's ignored by the 2D renderer...

    upload_2021-1-7_9-52-49.png

    The only solution I've found, is to increase the render scale, but that comes with quite a few other expenses and drops my frame rate almost in half :/

    With render scale 2:

    upload_2021-1-7_9-54-51.png