Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Shadow Clipping from Directional Light!! (Bias not working)

Discussion in 'Global Illumination' started by SomeGuy22, Jul 30, 2015.

  1. SomeGuy22

    SomeGuy22

    Joined:
    Jun 3, 2011
    Posts:
    722
    I have a directional light with realtime shadows in my scene. Everything works as expected but shadows seem to clipped on everything:



    ^Those objects are in fact touching the floor.

    This looked exactly like a shadow bias problem but the bias is 0! It can't decrease any more! Moving the shadow bias up moves the shadow further away like normal, but that is what shadows look like at bias 0.

    After reading into it, some people had said it might be an issue with shadow calculations themselves. Is it possible that I just reached the minimum object size for shadows? I based things off of 1 Unity Unit = 1 meter so I'm thinking I should have avoided that problem. If anyone has any ideas, thanks in advance!
     
  2. ImpossibleRobert

    ImpossibleRobert

    Joined:
    Oct 10, 2013
    Posts:
    517
    I experience exactly the same. I reported it on 28.July with a project attached already under 715786 but so far did not hear anything back. It's really worrying me as I think that is also the reason why ambient occlusion baking is not working for me.
     
  3. SomeGuy22

    SomeGuy22

    Joined:
    Jun 3, 2011
    Posts:
    722
    I tried baking Ambient Occlusion as well to hide the problem, but I got an ugly mess of spots and lighting errors.

    On a side note, baking anything takes a ridiculous amount of time. Even after disabling static terrain and lowering resolution to 10, it still took several hours to bake the scene. (Far too long to work on a level properly...) Not to mention the insane amount of lighting errors. If I had to work to fix every single one, and bake every time just to see the results, it would take well over a year :(

    I wish there was an option to go back to Beast... Or maybe I'm missing something but if I want to ignore Global Illumination and JUST BAKE SHADOWS I don't see any option for that. Shadow baking alone should only take a couple of minutes, but instead I'm forced to use GI just to get mixed shadows. (Which I don't think even works... I've heard a lot of times that mixed lighting is broken... even though it worked just fine in 4.5)