Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Service not available

Discussion in 'Linux' started by spacepluk, Aug 26, 2015.

  1. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    243
    Hi there,
    I'm trying to run the platform agnostic installer on Arch Linux and I get this error when trying to log in.

    http://i.imgur.com/fecuzvb.png

    Any idea?
     
  2. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    243
    The network seems to be fine and the windows version works under wine.
     
  3. unityuser1324235141

    unityuser1324235141

    Joined:
    Apr 5, 2013
    Posts:
    44
    I'm also running Arch and I get this exact problem.
     
  4. Deleted User

    Deleted User

    Guest

    Hey i also have this problem. I am on void linux. The editor.log in .config/unity3d says

    [CEF] Service not available, please try again later. in file:///%2Fhome%2Falex%2FDownloads%2Funity-editor-5.1.0f3%2FEditor%2FData%2FResources%2FHome/src/pn-login/login.js at line 96
     
  5. FionaSarah

    FionaSarah

    Joined:
    Aug 26, 2015
    Posts:
    11
    Arch here, same problem, same error in log. Can't seem to solve this one.
     
  6. unityuser1324235141

    unityuser1324235141

    Joined:
    Apr 5, 2013
    Posts:
    44
    Upon reading the login script, it turns out you can press escape to skip the login but then it gets stuck on Connecting.
     
  7. Zuntatos

    Zuntatos

    Joined:
    Nov 18, 2012
    Posts:
    612
    Same here, on manjaro
     
  8. Arial7

    Arial7

    Joined:
    Aug 26, 2015
    Posts:
    2
    +1 on Arch Linux
    Also can confirm what luckruns0ut said, if I press Escape, it hangs on Connecting
     
  9. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    243
    It looks like angular get's confused when it handles the CORS requests and it calls the error callback even though the server answers with 200. I don't understand why it doesn't happen in other distros though :/
     
  10. haagch

    haagch

    Joined:
    Nov 9, 2014
    Posts:
    34
  11. Zuntatos

    Zuntatos

    Joined:
    Nov 18, 2012
    Posts:
    612
    Well, after checking the network traffic of the unity editor not getting service, I can fully say: It indeed doesn't get service. It doesn't send or receive anything.
     
  12. ronjouch

    ronjouch

    Joined:
    Aug 26, 2015
    Posts:
    4
    Confirmed here under Arch Linux x64
     
  13. Deleted User

    Deleted User

    Guest

    Same here on gentoo ;(
     
  14. spacepluk

    spacepluk

    Joined:
    Aug 26, 2015
    Posts:
    243
    it looks like the embedded browser is blocking the CORS requests.
     
  15. Xoslorg

    Xoslorg

    Joined:
    Oct 29, 2013
    Posts:
    1
    Same here on Archlinux
     
  16. unity-freestyle

    unity-freestyle

    Joined:
    Aug 26, 2015
    Posts:
    45
    Same here on Manjaro
     
  17. jenrik

    jenrik

    Joined:
    Jun 23, 2014
    Posts:
    2
    I'm also having problems under archlinux
     
  18. Jackneill

    Jackneill

    Joined:
    Mar 13, 2013
    Posts:
    3
    same here on archlinux
     
  19. Deleted User

    Deleted User

    Guest

    Is there a workaround ?
     
  20. tkoole

    tkoole

    Joined:
    Aug 11, 2015
    Posts:
    3
  21. Deleted User

    Deleted User

    Guest

    Thanks, workaround there worked :)
     
  22. dogol

    dogol

    Joined:
    Feb 5, 2017
    Posts:
    3
     
  23. dogol

    dogol

    Joined:
    Feb 5, 2017
    Posts:
    3
  24. Dragan_S

    Dragan_S

    Joined:
    Feb 9, 2017
    Posts:
    1
    LD_PRELOAD=/lib/x86_64-linux-gnu/libresolv.so.2 /opt/Unity/Editor/Unity
    Type that in the terminal and complete all the entries that are required. After that Unity will be working just fine.
     
    kishankr_, JanarJack, JnMrtn and 3 others like this.
  25. V-V-Ch

    V-V-Ch

    Joined:
    Mar 23, 2017
    Posts:
    1
    Whhooooooo man , Thank you so match . It was my solution
     
  26. Tak

    Tak

    Joined:
    Mar 8, 2010
    Posts:
    1,001
    This issue isn't still occurring with recent builds, is it? I thought that it was only the very early ones?
     
  27. narendranaramala

    narendranaramala

    Joined:
    Apr 14, 2017
    Posts:
    1

    Awesome.. that worked..!!
     
  28. MeatyChief

    MeatyChief

    Joined:
    May 11, 2017
    Posts:
    1
    That is not arch only. I'm using Zorin OS (Ubuntu based... well Debian I guess :D) Had same problem. That solved it though. Thx A lot :)
     
  29. GG1407

    GG1407

    Joined:
    Jul 29, 2017
    Posts:
    1
    Nice! Working on ElementaryOS (Ubuntu based)
     
  30. locashgamer

    locashgamer

    Joined:
    Dec 12, 2016
    Posts:
    1
    I tried that on Linux Mint and it says:

    /opt/Unity/Editor/Unity: /opt/Unity/Editor/Data/Tools/libgpg-error.so.0: no version information available (required by /lib/x86_64-linux-gnu/libgcrypt.so.20
     
  31. abhafez

    abhafez

    Joined:
    Mar 11, 2017
    Posts:
    1
    try

    LD_PRELOAD=/lib/x86_64-linux-gnu/libresolv.so.2 /opt/Unity/Editor/Unity

    in terminal .. login and then it will work normally
     
    willemsenzo likes this.
  32. willemsenzo

    willemsenzo

    Joined:
    Nov 15, 2012
    Posts:
    585
    Thanks this worked for me on Linux Mint 18.3
     
  33. randriese

    randriese

    Joined:
    Mar 11, 2018
    Posts:
    1
    I'm on Mint as well, 18.03 to be precise.

    After running: LD_PRELOAD=/lib/x86_64-linux-gnu/libresolv.so.2 /opt/Unity/Editor/Unity in a terminal I could run Unity and login without issues