Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  5. Nominations have been announced for this years Unity Awards. Celebrate the wonderful projects made by your peers this year and get voting! Vote here!
    Dismiss Notice
  6. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  7. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Seriously what is this "optimized game object hierarchy" ..and why is it making my life so bad ! :-(

Discussion in 'Animation' started by ashc91, Nov 30, 2016.

  1. ashc91

    ashc91

    Joined:
    Aug 27, 2016
    Posts:
    41
    i have the unity survival shooter tutorial and When i click on the player , select animation window , everything is greyed out and it says "Editing and playback of animation on optimized gameobject heirarchy is not supported "

    I am looking to tweek the animation of the player in the animation window to study how it works . Now how can i make this window show all the animation of the player like how its supposed to be like ?


    I Cant find any help or information regarding this on google. am sure If you could help me out with this its gonna be usefull for a lot of frustrated newbies like me .

    thanks in advance .
     

    Attached Files:

  2. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    5,076
  3. ashc91

    ashc91

    Joined:
    Aug 27, 2016
    Posts:
    41
    thanks for the advice , I selected the character and turned off 'optimize gameobjects' and 'optimize mesh' option (please see the attachment )). selected "reimport" from charachter assets folder , but still the the animation panel is grayed out and says Editing and playback of animation on optimized gameobject heirarchy is not supported "
     

    Attached Files:

    • 2222.jpg
      2222.jpg
      File size:
      405.4 KB
      Views:
      295
    Last edited: Nov 30, 2016
  4. AcidArrow

    AcidArrow

    Joined:
    May 20, 2010
    Posts:
    5,076
    Do it for all objects in that hierarchy (I also see a gun object? I don't know what else)
     
  5. ashc91

    ashc91

    Joined:
    Aug 27, 2016
    Posts:
    41
    I did that for all the characters and objects ,still the same :-( .By the way the character player is not a humanoid ,its generic , i dont know if that the issue .I guess unity doesnt want people to mess around with this player character.

    anyways thanks for you help :)
     
  6. DavidGeoffroy

    DavidGeoffroy

    Unity Technologies

    Joined:
    Sep 9, 2014
    Posts:
    267
    Unless there's a bug (which is possible), the asset you are previewing the animations on is still optimized.
    Probably, the instance in the scene is still optimized, and this is what you are previewing on.
     
  7. DavidGeoffroy

    DavidGeoffroy

    Unity Technologies

    Joined:
    Sep 9, 2014
    Posts:
    267
    Also, the option you are looking to disable is OptimizeGameObjects in the Rig panel.
    The other one is unrelated
     
  8. Baste

    Baste

    Joined:
    Jan 24, 2013
    Posts:
    3,472
    The optimization can be turned off on the animator on the object. Click the little wheel thing next to the animator.

    There's a bug where if you have the animation window open when you turn off the optimization, it'll still show grayed out until you select a different animator or close/open the window again.

    @DavidGeoffroy, is there any way for us to check in code if an animator is optimized? There's a very nice API for doing the optimization from code,but I haven't found any way to check if it is optimized. I know that's available internally, as both the animation window and the drop-down on the animator's wheel changes based on if it's optimized, so I assume it's just not exposed?
     
  9. ashc91

    ashc91

    Joined:
    Aug 27, 2016
    Posts:
    41
    Thanks a lot guys . Appreciate your support .God bless u guys.
     
  10. Salim

    Salim

    Joined:
    Apr 25, 2011
    Posts:
    137
    I know this is an old post, but I got the same problem today (Unity 2017.2.0f3). The bug is that re-importing a model with the setting Optimize Game Objects turned off does not update the instances in the scene or the prefab.
    The way I got around this problem is by recreating a new prefab from scratch.
     
  11. facejets

    facejets

    Joined:
    Oct 7, 2018
    Posts:
    2
    @Salim - if there was a bug there, its fixed. no need to chuck the prefab; just delete the instance from the hierarchy and drag a new one in.

    There are two issues being discussed here, making this confusing. One is that changing the import settings for a prefab doesn't change an instance that is in hierarchy, at least until you select that instance again, or mouseover the animation tab, but what was stopping OP is that the animations in this tutorial are read-only.

    of minor interest is that in the upper right corner of the inspector there is a debug mode that lets you play with certain values, but only the ones in the inspector. But, with some prodding, I replicated solution for someone trying to do what OP was trying to do.

    it is: switch inspector to debug mode, in Assets > Models > Characters expand Player, select a read-only clip from inside and type ctrl-d to duplicate it. Remove all the old states from animator tab (the mechanim nodes) and replace with the dupe, wiring a transition from start to it, then in animation, - which is not the (mechanim) animator - click an entry and arrow up until you reach the top (because the blank line at the top causes all entries to be selected) and then play with the values in either dope sheet or curves. (if in curves, typing 'a' will scale the mess to the window)

    i jacked that dude all up, and it felt good.

    thanks https://forum.unity.com/threads/removing-read-only-from-animation-clips.514549/#post-3371017