Search Unity

serial failed to validate - empty hwid from client.

Discussion in 'Unity Hub' started by Skjalg, May 11, 2018.

  1. Skjalg

    Skjalg

    Joined:
    May 25, 2009
    Posts:
    141
    Hi.

    I just updated windows 10 to version 1803. When rebooting it asked me for permission to use my location, permission to use my advertising id etc. And I said no to every one of them.

    When starting Unity HUB it prompted me for a serial and when I inserted it It gives me "serial failed to validate - empty hwid from client". My guess is that I have now revoked the possibility for programs to access my advertising identifier and the unity serial thing is dependant on that.

    Unity Hub_2018-05-11_13-05-30.png

    I feel like I have been spending more time struggling more with the unity serial in this program than I have actually saved by using it. Why does this tool need me to sign in or ask for a serial? Its two jobs is to open the correct unity version for a project (which requires a separate unity serial window) and install unity versions (which should not require a serial).
     
  2. Skjalg

    Skjalg

    Joined:
    May 25, 2009
    Posts:
    141
    I opened my unity project the old way by locating the correct unity exe file and opening my project. The next time I wanted to open Unity HUB it worked without me having to enter my serial again. So it somehow found out I had a valid serial again.
     
  3. zedarus

    zedarus

    Joined:
    Mar 2, 2012
    Posts:
    5
    Also happened to me both on Windows 10 and macOS. Only managed to make it work again by launching Unity manually.
     
    unity_X86DaQSY64b4Rg likes this.
  4. lloydhooson

    lloydhooson

    Joined:
    Apr 7, 2008
    Posts:
    57
    This just happened to me too.
     
  5. msloan7

    msloan7

    Joined:
    Sep 5, 2012
    Posts:
    3
    I just ran into this as well. Whats the fix?
     
  6. mstevenson

    mstevenson

    Joined:
    Sep 24, 2009
    Posts:
    168
    I'm stuck behind this bug, too. Here are my repro steps:

    1. Logged into Unity Hub.
    2. Entered my serial number. A small label appeared beneath the text field noting that my serial number was valid.
    3. Pressed the "next" button.
    4. The entire window flashed white and returned me to the same serial entry field screen, but this time the breadcrumb UI at the top of the window was missing.
    5. Removed and re-entered my serial number. It was verified a second time.
    6. Pressed the "next" button. Nothing happened. Pressed "next" many more times without a response.
    7. Relaunched Hub.
    8. Entered my serial number. I was presented with the error mentioned in the original post.
    9. Logged out of Hub.
    10. Looped back to step #1. The same issue occurs 100% of the time.
     
  7. noemis

    noemis

    Joined:
    Jan 27, 2014
    Posts:
    34
    This happend to me after a windows 10 update (Oktober Update). A restart of the unity hub helped.
     
  8. GeoffBot

    GeoffBot

    Joined:
    Oct 25, 2018
    Posts:
    1
    Getting this, too.
     
  9. bsawyer

    bsawyer

    Joined:
    May 6, 2014
    Posts:
    26
    Can confirm quitting Hub, and relaunching solves the issue for me. Still had to enter my license again but validation succeeded.
     
  10. AndyKorth

    AndyKorth

    Joined:
    Oct 19, 2009
    Posts:
    19
    This started happening for me at the Global Game Jam. I figured it had to do with the spotty internet. But it continued happening at home. It seems like re-entering my key and then restarting the Hub fixed it, but it still happens every few days.

    Keep your subscription page open, I guess: https://id.unity.com/en/subscriptions

    edit: It also told me I didn't have any editors installed in the hub, but clicking around on the tabs would properly list the installed editors. So if you see that, also restart your hub.
     
  11. McDev02

    McDev02

    Joined:
    Nov 22, 2010
    Posts:
    591
    I have this issue since the HUb came out as a Beta. As it seems to be a requirement for 2019 I wrote to support agian, I need a solution.

    Attempt 1
    First I got an error like "invalid hwid" when I tried to activate my license.
    After that I tried manual activation and it seemed to work.
    But whether I open my project with the Unity Hub or from Unity 2019 I see the Licence Error page. Wheter I start it with admin rights or not.

    Attempt 2
    After I disabled my Security Programm and allowed connection in the windows firewall which popped up when starting the HUB, the license seemed to be activated, the headline "Activation" pops up for a second. Right after that the window to enter a license comes up again. But either nothing happens when I press OK or I am directed to the "License Error" Page after a bit.

    I wonder what the difference is between the Hub and the 2018 Launcher, they look exactly the same and I have no issues with the Launcher.
     
    Last edited: Feb 5, 2019
  12. mathieub

    mathieub

    Unity Technologies

    Joined:
    Jun 28, 2017
    Posts:
    46
    Hi @McDev02,

    Sorry for the inconvenience.
    Could you please fill-in a bug with the Hub's bug reporter (see FAQ) so we can troubleshoot the problem.

    As for your question, the biggest difference for now between Hub and the Legacy Launcher lies in the fact that Hub helps you manage your Unity Editors (downloading, installing, ...).

    More on the topic on this article of the Unity Blog here.
     
  13. McDev02

    McDev02

    Joined:
    Nov 22, 2010
    Posts:
    591
    @mathieub Thanks I did just now.
    I know how the Hub works and it is great, I only wondered if the license management or whatever is being handled differently.
     
    mathieub likes this.
  14. bricefr

    bricefr

    Joined:
    May 3, 2015
    Posts:
    5
    Same here using the last Hub version (no beta) on Windows 10.
    Works fine on macOS for the record.