Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Selected texture format 'ARGB 16 bit' for platform 'DefaultTexturePlatform' is not valid with the cu

Discussion in 'Editor & General Support' started by Jason-K, Jun 21, 2019.

  1. Jason-K

    Jason-K

    Joined:
    Dec 1, 2014
    Posts:
    35
    Whenever I try to bake lighting I get the following error:

    Selected texture format 'ARGB 16 bit' for platform 'DefaultTexturePlatform' is not valid with the current texture type 'Default'.

    I don't know exactly what it means. I'm guessing I have a texture somewhere in my project set to ARGB 16 bit and I need to change it to something else, but that's just a guess. I did some searching and found other people posting the same problem elsewhere but I cannot find a fix to it. If it is a texture that I need to change, is there an easy way to find that specific texture in a massive project? I tried searching for "Texture" in the project hierarchy but that only returns a huge list of folders labelled Textures and there are way too many of them to search through manually thanks to all the asset packages I've downloaded.

    Edit: We're able to get around this issue by using Baked Indirect lighting instead of Shadowmask. If we find a more proper solution we'll post it here for anyone who finds this and isn't okay with Baked Indirect lighting in their game.
     
    Last edited: Jun 21, 2019
  2. Laumania

    Laumania

    Joined:
    Jun 27, 2012
    Posts:
    151
    I'm facing the same...and the baking never seems to stop. I'm listening to what you find :)
     
    zetaFairlight likes this.
  3. santins

    santins

    Joined:
    Jun 26, 2015
    Posts:
    1
    I have the same issue... The only workaround as mentioned is using Indirect lighting as lighting method. If I find a better solution I'll post here
     
    zetaFairlight likes this.
  4. RomainH

    RomainH

    Joined:
    Oct 8, 2015
    Posts:
    2
    I got the same issue and I found that the generated texture called "Lightmap-0_comp_shadowmask" has no valid format in the Inspector. There is an error message just below this parameter.
     
  5. spockTheGray

    spockTheGray

    Joined:
    May 13, 2017
    Posts:
    2
    yl_tys likes this.
  6. Kay-Mighty

    Kay-Mighty

    Joined:
    May 9, 2017
    Posts:
    8
    Facing the same issue here, the problem is the shadowmask lightmap texture that has been generated. A solution I figured out for now is to select the "android Icon" as default texture platform in the inspector window (P.S developing for android)
     
  7. NeatWolf

    NeatWolf

    Joined:
    Sep 27, 2013
    Posts:
    896
    2020/01/04, Unity 2019.3.0f3, and the bug is still there :S
    Is there any way to automate applying the correct setting to the texture?
    Also which is the correct format for it?
     
    soleron likes this.
  8. christianmahler

    christianmahler

    Joined:
    Jul 9, 2017
    Posts:
    31
    You can use the AssetPostprocessor for auto setting texture platform setting.
     
  9. soleron

    soleron

    Joined:
    Apr 21, 2013
    Posts:
    219
    Yup, bug is still here.
    If it is not a bug, someone should remove it from the console.
    If it is still meant to be seen but does nothing, put it in warnings.

    How?
     
  10. Alan47

    Alan47

    Joined:
    Mar 5, 2011
    Posts:
    148
    2019.2.18.f1 user here - I can confirm that this bug is still present. I can't tell if it has any implications beyond that error message though.
     
  11. M4R5

    M4R5

    Joined:
    Apr 11, 2013
    Posts:
    29
    bump 2019.3.3f1
     
    Kingblade likes this.
  12. Bill-Sansky

    Bill-Sansky

    Joined:
    Oct 2, 2016
    Posts:
    68
    same here!
     
  13. cineconcerts

    cineconcerts

    Joined:
    Dec 18, 2019
    Posts:
    9
  14. thieum

    thieum

    Joined:
    Apr 8, 2011
    Posts:
    56
    You can just set the Lightmap-0_comp_shadowmask.png format to "automatic" in the Inspector after all.
     
unityunity