Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Script Order Execution - Drag & Drop Not Working (2019.4.8f1)

Discussion in 'General Discussion' started by NathanielAH, Aug 13, 2020.

  1. NathanielAH

    NathanielAH

    Joined:
    Jul 22, 2013
    Posts:
    54
    I am trying to manually add a script to the Script Execution Order (SEO) screen.

    The comments I've seen are to "drag and drop. If you look at the screenshot, I've selected the script, am dragging on to the SEO, and it shows a blocked symbol.

    The only alternative is to use the horrible scrolling menu (that doesn't even support a scroll wheel).

    Any suggestions, am I doing it wrong, or is this a new bug?

    I'm on 2019.4.8f1 for reference.

    IMG_4192.jpg
     
  2. JohnnyA

    JohnnyA

    Joined:
    Apr 9, 2010
    Posts:
    4,883
    Just in case it is not what you are doing: click the + button (bottom right of list) to add the script, then drag the script once added to reorder the list.
     
  3. NathanielAH

    NathanielAH

    Joined:
    Jul 22, 2013
    Posts:
    54
    I don't think that fits what I'm getting at. I can click the dropdown to find any script currently noted via slow click scroll. It actually breaks if I click the +; nothing happens. If I click the arrow, the window opens but if I don't add anything and click away then click back I have to close the entire window and re-open for it work again. Not the point of this issue, but still something of note.

    The issue I am experiencing is dragging from the project window to the SEO window and dropping in the script to add it to the list.

    Examples can be found at the below:


    That is what doesn't work.

    Or perhaps I'm misunderstanding your directions?
     
  4. JohnnyA

    JohnnyA

    Joined:
    Apr 9, 2010
    Posts:
    4,883
    No probs, thought you might be able to get to it that way. Drag to add also working fine for me, although I'm not 8f1. Have you tried in a new project? Have you tried with a slightly different version?
     
  5. NathanielAH

    NathanielAH

    Joined:
    Jul 22, 2013
    Posts:
    54
    So in an empty project on 2019.4.8f1 it works for the same script. For whatever reason the SEO window is locked to having the script added. Tried on different scripts, same issue.
     
unityunity