Search Unity

  1. We've closed the job boards. If you're looking for work, or looking to hire check out Unity Connect. You can see more information here.
    Dismiss Notice
  2. We're running great holiday deals on subscriptions, swag and Asset Store packages! Take a peek at this blog for more information!
    Dismiss Notice
  3. Check out our Unite Austin 2017 YouTube playlist to catch up on what you missed. More videos coming soon.
    Dismiss Notice
  4. Unity 2017.2 is now released.
    Dismiss Notice
  5. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  6. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  8. Unity 2017.3 beta is now available for download.
    Dismiss Notice

Script not Launching after SetActive

Discussion in 'Scripting' started by JulienGn, Sep 13, 2017.

  1. JulienGn

    JulienGn

    Joined:
    Sep 13, 2017
    Posts:
    3
    Hello,

    so I'm rather new in Unity and struggle to complete a feature I'm trying to implement for a group project.
    Basically I have a script automatically launching a video into a RawImage object, but this RawImage needs to be deactivated untill the user SetActivate it throught another script I launch from a Button object.

    While I press the button, the RawImage seems to be activated and is visible, but the script doesn't automatically starts, and the video does not play.

    Am I missing out something here ? Have I to run a specific command to force the video script to launch ?

    Thanks.
     
  2. JulienGn

    JulienGn

    Joined:
    Sep 13, 2017
    Posts:
    3
    Edit : Welp, nevermind.
    That was because I didn't redirect correctly my method calls into Update().