Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

RuntimeNavMeshBuilder: Source mesh xxxxxxxxxxxxxxx does not allow read access.

Discussion in 'General Graphics' started by garrettstamand, Jan 13, 2018.

  1. garrettstamand

    garrettstamand

    Joined:
    Nov 25, 2017
    Posts:
    4
    "This will work in playmode in the editor but not in the player."

    I bought an asset pack, but when i try to use the prefabs in a scene I get that error for every single one. Apparently all the models do not allow read access. I cannot for the life of me figure out how to enable read access, why it would be disabled by default, or why I am running into this problem when googling suggests that nobody else has.

    Any help would be greatly appreciated.
     
    MarkTension likes this.
  2. Antony-Blackett

    Antony-Blackett

    Joined:
    Feb 15, 2011
    Posts:
    1,779
    You should be able to select the asset and on the Model Importer settings there should be a check box 'Read/Write Enable'.
     
    Last edited: May 5, 2021
  3. garrettstamand

    garrettstamand

    Joined:
    Nov 25, 2017
    Posts:
    4
    Can't believe I missed that. Thanks a lot
     
  4. fluffyfrogstudios

    fluffyfrogstudios

    Joined:
    Aug 10, 2018
    Posts:
    3
    nice. cant believe i missed this as well
     
  5. atur94

    atur94

    Joined:
    Apr 7, 2019
    Posts:
    11
    nice. I also missed it that
     
  6. niuage

    niuage

    Joined:
    Nov 17, 2019
    Posts:
    123
    Phew, that fixed it.
     
  7. jason_skillman

    jason_skillman

    Joined:
    Feb 1, 2020
    Posts:
    11
    Thanks a bunch, that did the trick.
     
  8. cosmicninja

    cosmicninja

    Joined:
    Jan 19, 2013
    Posts:
    2
    I bumped into this error message and even though my models were enabled for read/write and static was ticked off
    the problem still persisted.
    So I tried In the Inspector / on NavMeshSurface panel setting the Use Geometry option to Physics Collider.
    Now it works.
     
    Karabin and RobinHut3 like this.
  9. Recluse

    Recluse

    Joined:
    May 16, 2010
    Posts:
    485
    I'm getting this a lot. Problem is, I don't want the meshes to be readable, nor do I want them to be considered for navigation. How can I ensure the runtime Navmesh builder ignores them?
     
  10. ViktorBrenek

    ViktorBrenek

    Joined:
    Jun 12, 2021
    Posts:
    2
    Thanks brother. Saved me a lot of time.
     
  11. noob_render

    noob_render

    Joined:
    Apr 20, 2020
    Posts:
    1
    thanks man
     
  12. MALGOW

    MALGOW

    Joined:
    Feb 18, 2017
    Posts:
    4
    life saver
     
  13. DYV

    DYV

    Joined:
    Aug 10, 2015
    Posts:
    59
    Thanks a lot!